10

My ubuntu 13.04 machine (ASUS M2n32SLI deluxe mobo) is loading one of two interfaces on the motherboard as "rename3". The other interface is eth0. No cable connected on eth0.

  1. Why is this so ?
  2. How do I fix this? I want to retain dynamic dns.
9

How to rename Network interfaces:

Here is one solution, on how to rename the interface. Most likely, there was something which went wrong under the setup of the device, so, let's roll on with it:

Open the file

/etc/udev/rules.d/70-persistent-net.rules

And look for "rename3" in it. You will find this: NAME="rename3" on a pretty long line, so i suggest that you open the file in "gedit", and search for that word by pressing ctrl+f.

Command for that: sudo gedit /etc/udev/rules.d/70-persistent-net.rules

When you find it, edit it to desired name, like NAME="wlan0" (if not taken) or something, that you can recognize it easily.

On the same line, you'll find another parameter called KERNEL=="rename3". You don't have to edit this "kernel" parameter, as i am unsure myself what it is for. It works without changing that.

Now save the file, and close it.


After doing this, remember also to check your /etc/network/interfaces file to reflect the interface’s name change.

Restart the service:

/etc/init.d/networking restart

Done!

| improve this answer | |
  • 3
    I do not have "rename7" in that file. This is a mystery -- sometimes, but not all times, rebooting causes p1p2 to become rename6, rename7, etc. – Michael Graff Mar 20 '14 at 19:51
  • 1
    Hi @MichaelGraff I have the same problem as you. I do not have any rules specified for udev, and my interface gets renamed from p1p2 to rename3, etc. but not on every boot. So some day it works, some other not. I have opened a Bug #1284043 (bugs.launchpad.net/ubuntu/+source/systemd/+bug/1284043) you can tell the maintainer on this tracker that this bug affects you too. – Huygens Apr 5 '14 at 22:14
5

Not claiming to be an expert here, but here is what I found. After seeing one of my interfaces named "rename2", I checked the file /etc/udev/rules.d/70-persistent-net.rules. There I could see that both my second and third NIC had the same name, eth1. After changing the last of them to eth2, and rebooting, everything was back to normal.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.