1

I take full blame for this, but I screwed over my system and don't know what to do next. Here's what happened, and I hope someone can give me advice on next steps.

  • I have an Acer Aspire one, originally with windows 8.
  • I put 13.04 on a usb drive and successfully installed it. during the install, I removed all existing partitions etc, completely nuked windows 8 (yay!)
  • I used full disk encryption (I still have this password)
  • Everything worked fine, and THIS is where I made a mistake
  • I decided I wanted to try another distro, and while I was downloading it, I decided to use the same Ubuntu USB stick to boot up, then opened gparted, and 'deleted' the partitions on the hard drive. The download of the other distro I wanted to try (OpenSUSE) was taking too long so I went to bed.
  • Woke up, decided "you know what, I'll stick with Ubuntu" and so decided to reinstall from the same USB drive. This time i did NOT choose disk encryption, other than that, install was exactly the same.
  • Install seemed to go fine. At the end, I removed the USB drive, restarted.
  • System message came up saying "no bootable device"
  • Re did installation, same problem
  • Freaked out, decided to try to use my OpenSUSE thumbdrive to install THAT distro, during installation, OpenSUSE recommended deleting all the existing partitions of ubuntu etc, which I allowed it to do. Install went fine but after removing thumbdrive and restarting am still getting: "no bootable device"
  • Tried to do some research, some places indicating that I should be in legacy bios mode etc, but on my original install I was on UETF and it was fine. Tried switching that in the BIOS and restarting. Got a little further (OpenSUSE command line items started appearing, so I think it was starting to load up) but eventually got bootable device message again.

So I think I screwed up here. I am assuming this has something to do with the initial choice to encrypt the hard drive. Or I messed up the partition tables, or similar.

I don't care about any lost data, all I want to do now is put in my Ubuntu USB thumbdrive, wipe out all previous data, and install Ubuntu again from scratch.

I would really appreciate a step by step. I feel very lost on this.

  • Just for the record, making a ubuntu usb install drive and trying to run that does not work? Does a live CD work? This might be because there is no UEFI partition. If you can set your bios to legacy mode, you should be able to reinstall despite the encryption (at least that is what I think). – don.joey Oct 7 '13 at 7:13
  • Hi don.joey ---- I can run off of the USB drive no problem. Also another piece of information: When I try to start OpenSUSE (from the hard drive) the message I get is: OpenSUSE has been blocked by the current security policy. Does that provide any further clues? – user199467 Oct 7 '13 at 7:24
0

No bootable device means you do not have grub installed, not the distro. Just remember on clicking on of the /dev/sda partitions and the one in /dev/sdb as the partition for grub and all will be ok.

  • I'm sorry, could you restate that? I'm actually not sure what you are saying =( – user199467 Oct 9 '13 at 1:56
  • When you install from USB, it selects /dev/sdb1 as the bootable partition and where grub is installed. – NotFromBrooklyn Oct 9 '13 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.