1

I ran cmake to compile BLender then I got this error:

Couldnt find boost

I have already installed libboost* 1.53 dev

How can Cmake find boost? What should I add to Cmakelist.txt?

2

You may be missing some dependencies required for installing Blender. The libboost* dependencies for Blender in Ubuntu 13.04, 13.10 and 14.04 are as follows1:

  libboost-filesystem
  libboost-locale
  libboost-system
  libboost-thread

The libboost* dependencies for Blender in Ubuntu 16.04 are as follows:

  libboost-filesystem1.58.0
  libboost-locale1.58.0
  libboost-system1.58.0
  libboost-thread1.58.0

The libboost* dependencies for Blender in Ubuntu 18.04 are as follows:

  libboost-locale1.65.1
  libboost-system1.65.1
  libboost-thread1.65.1

The libboost* dependencies for Blender in Ubuntu 18.10, 19.04 and 19.10 are as follows:

  libboost-locale1.67.0
  libboost-system1.67.0
  libboost-thread1.67.0

All of these dependencies can be installed from the default Ubuntu repositories. Check at the link mentioned above to make sure that the libboost* versions selected are at least as current as the versions specified in the link, as there are multiple versions of libboost* available in the default Ubuntu repositories (all of which are from the universe repository).

1Blender in Ubuntu 12.04 and Ubuntu 12.10 does not require these four libboost packages.

0

Try these changes in your CMakeLists.txt

set(Boost_USE_STATIC_LIBS OFF)

in CMakeLists.txt it will work. For me, it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.