I've been trying to install Ubuntu Server 12.04 LTS i386 from a CD-ROM on a Pentium IV 3GHz machine, always with the same problem - it doesn't manage to install linux-image-3.8.0-29-generic. I checked the MD5 Check Sum of the ISO file and it is OK. I checked the integrity of the CD-ROM and it is also OK. The error reported from syslog is transcript below (it is impossible to copy it from the console by this time):

Errors were encountered while processing:
Sub-process /usr/bin/dpkg returned an error code (1)
Reading pagckage lists...
Building dependency tree...
linux-headers-generic-lts-raring is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
linux-image-generic-lts-raring: Depends: linux-image-3.8.0-29-generic but it is not going to be installed
Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)

The suggested solution of apt-get -f install was innocuous, as the system couldn't find 'apt-get'. It also couldn't find dpkg.

I have previously installed Ubuntu 12.04 LTS Desktop in this same machine with no problems at all. Now I would like very much to run the Server version, as all I want to do is build a small server. What can I do to solve this problem, please?



It was my mistake :( After having tried everything else, I decided to start all over, repartitionning the disk and so on. When repartionning the disk I found that the partition "/boot" had been asigned only 1 MB, instead of 1 GB, as planned. Obviously there wasn't enough space to put the system there. Just brought it up to 1 GB and, voilà! Problem solved. Anyway, the installer could very well have detected this and signaled the lack of space! It would have been much simpler.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.