Some PDFs render inside Firefox. I am very unhappy with that for several reasons.

Since Ubuntu ships with a good, stable and lightweight PDF-viewer, evince, I'd rather have all PDFs handled by that native viewer instead of the Firefox one.

I suspect it's because of either the mine-type, some extension, a disposition-header or some combination thereof, but some PDFs open already just fine in Evince. Others still open in the PDF.js.

How can I direct all PDFs to the native, evince, viewer?

2 Answers 2


If you'd rather not use the built-in PDF Viewer, you can use another PDF viewer like Evince or another default viewer on Ubuntu.

To switch from the built-in PDF viewer to another PDF viewer:

  1. At the top of the Firefox window, click on the Edit menu and select Preferences
  2. Select the Applications panel.
  3. Find Portable Document Format (PDF) in the list and click on it to select it.
  4. Click on the drop-down arrow in the Action column for the above entry and select the PDF viewer you wish to use.
  5. Click Close to close the Preferences window

enter image description here

(Source https://support.mozilla.org/en-US/kb/disable-built-pdf-viewer-and-use-another-viewer)

  • 2
    Thanks. I went one step "further" and chose "/usr/bin/gnome-open" instead. This means that Gnome (Ubuntu) will always choose the application that is set system-wide as PDF-viewer. On vanilla Ubuntu that will be "Evince, Document Viewer", but when I were to choose another PDF-reader Firefox will respect that change.
    – berkes
    Oct 7, 2013 at 7:46

The problem seems to be a setting in ~/.local/share/applications/mimeapps.list

It's this entry thats needs to be modified:

application/octet-stream=gedit.desktop (it may look different on your machine)

As soon as I changed this to:


firefox would suggest to open a .pdf file with evince instead of gedit

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .