I have been trying to install Ubuntu touch on Nexus 7 (grouper, WiFi) for a couple days now, and no luck. I am using manual install method (from this tutorial) because other automatic tools don't work. Also using Ubuntu touch daily pre-installed images.

I tried using Ubuntu recovery provided with other images, but received error and audodeploy.zip would not install after pushing it to /sdcard/autodeploy.zip

E: Can't open /cache /recovery/ubuntu_command
Can't find autodeploy.zip

I have also tried using CWM recovery, but no luck there either. Device just get's stuck on Google boot logo.

What am I doing wrong?

It looks like /sdcard is actually a link to /data/media/ which seems to get erased every boot.

  • What 'automatic' tools did you try, and how did these fail? The daily builds have generally worked (to install), but continue to exhibit issues (which vary) on Nexus 4, Nexus 7, and Nexus 10 - as changes break (or improve) existing features.
    – david6
    Oct 6 '13 at 21:26

I thought I had the same issue and the warning messages scared me, but I just waited a bit longer and it eventually continues on its own. I had to wait almost 10 minutes for that first screen to pass the:

E: Can't open /cache /recovery/ubuntu_command
Can't find autodeploy.zip

message. Maybe give it some more time.

Not the answer you're looking for? Browse other questions tagged or ask your own question.