I thoughtlessly removed my SD card from the slot of the card reader while the SD card was in use in gparted and the disk-utility. After I put it in again, it was not visible anymore. It is the same situation with another SD card. I reopened the disk-utility and the complete card reader doesn't appear anymore. I tried to restart the computer but the situation remains the same - The card reader doesn't appear in the disk-utility. How can I reactivate it?

  • Restart did not solve the problem - Restart after 5 min separated from any power source / power cable unplugged did solve problem.
    – aldorado
    Oct 6, 2013 at 21:01
  • Delete question or does it have value for other users?
    – aldorado
    Oct 6, 2013 at 21:03
  • Please post it as an answer. Remember, it's perfectly alright to ask and answer your own question.
    – jokerdino
    Oct 7, 2013 at 13:46

1 Answer 1


After the problem could not be solved by a simple reboot, the following procedure was successful: Switching off the computer, then removing any power source for 5 min (simply plugging off power supply cord). After reconnecting and booting, the card reader was detected again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .