0

I am the only user on my PC and do not want to enter my password. How do I disable? I do not want to enter a password every time my screen saver starts or I install any aps.

marked as duplicate by Elder Geek, Charles Green, Eric Carvalho, Zanna, Anwar May 11 '17 at 5:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    @Gordon, it is really a bad idea to disable the password altogether, see Madmike's answer below on how to disable it for the screen lock. The duplicate linked above will help you stop all passwords but, one of the biggest security advantages in Linux will be bypassed, and anyone, form anywhere can install a program on your computer(this includes viruses). With the password it is much more difficult to install malware, as the malware cannot get out of you home folder(at least not easily) and wreck your system files without the password. – TrailRider Oct 6 '13 at 1:35
  • To add to TrailRider's points - you're not only unnecessarily exposing yourself to the risks but others too if your system becomes compromised and abused. All at the cost of little convenience. It's a bit like people who don't vaccinate their kids thinking it's only their kids affected. A bit silly, to be diplomatic about it. – Marcin Kaminski Jan 8 '15 at 19:04
3

You can disable the password lock from the screen saver by opening a terminal and running gsettings set org.gnome.desktop.screensaver lock-enabled false.

1

Open the terminal window by pressing Ctrl+Alt+T and run the command:

sudo visudo

Find the line that says:

%admin ALL=(ALL) ALL

And change it to:

%admin ALL=(ALL) NOPASSWD: ALL

Save and exit the file

Source: http://www.ubuntugeek.com/how-to-disable-password-prompts-in-ubuntu.html

I must warn you though that disabling all security prompts could pose a major security risk and is extremely inadvisable.

Not the answer you're looking for? Browse other questions tagged or ask your own question.