My computer has a small SSD and a large regular HDD. I've got Windows on the SSD, and I've managed to take up nearly the whole thing, so I'd like to install Ubuntu on my larger HDD where I currently store my data. I've tried running the 12.10 installer from a live USB, but it doesn't seem to see the 'empty space' partition of the second hard drive - it just shows up with one massive /dev/sdb partition. I don't want to install to this in case it wipes my data out.

This is what my system looks like in Windows 7's partition editor. How do I get Ubuntu to notice the empty space in the second drive?

enter image description here

Since posting this, I merged the 'unused space' in the H: drive back into the allocated space, so it's now just one big partition. When I boot into Ubuntu, a disk icon shows up in the explorer labeled Data, but when I try to open it, I get a popup with this:

Error mounting /dev/sdb2 at /media/daniel/Data: Command-line `mount -t "ntfs" -o
"/dev/sdb2"     "/media/daniel/Data"' exited with non-zero exit status 12:
Failed to read last sector (1953514191): Invalid argument
HINTS: Either the volume is a RAID/LDM but it wasn't setup yet,
   or it was not setup correctly (e.g. by not using mdadm --build ...),
   or a wrong device is tried to be mounted,
   or the partition table is corrupt (partition is smaller than NTFS),
   or the NTFS boot sector is corrupt (NTFS size is not valid).
Failed to mount '/dev/sdb2': Invalid argument
The device '/dev/sdb2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

Here's some command output that may help:

daniel@daniel-ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 60.0 GB, 60022480896 bytes
255 heads, 63 sectors/track, 7297 cylinders, total 117231408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xb25702d7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   101315360    50554256+   7  HPFS/NTFS/exFAT
/dev/sda3       101316606   117229567     7956481    5  Extended
/dev/sda5       113231872   117229567     1998848   82  Linux swap / Solaris
/dev/sda6       101316608   113231871     5957632   83  Linux

Partition table entries are not in disk order

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
240 heads, 63 sectors/track, 129201 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3fa2eb82

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1              63  1953523119   976761528+  42  SFS


daniel@daniel-ubuntu:~$ sudo parted -l

Model: ATA INTEL SSDSC2CT06 (scsi)
Disk /dev/sda: 60.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type      File system     Flags
 1      1049kB  106MB   105MB   primary   ntfs            boot
 2      106MB   51.9GB  51.8GB  primary   ntfs
 3      51.9GB  60.0GB  8147MB  extended
 6      51.9GB  58.0GB  6101MB  logical   ext4
 5      58.0GB  60.0GB  2047MB  logical   linux-swap(v1)

Model: ATA SAMSUNG HD103SJ (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      32.3kB  1000GB  1000GB  primary

Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: /dev/sr0: unrecognised disk label  

1 Answer 1


You say in your question that the Ubuntu installer "...just shows... one massive /dev/sdb partition." In Linux terminology, /dev/sdb is a disk identifier -- it refers to the entire disk, not to any partition on the disk. The disk might in principle have one massive partition (say, /dev/sdb1), which would be one problem; but if the partitioning tool is showing /dev/sdb as being unallocated (with no partitions), then that's an entirely different problem.

In the former case (one /dev/sdb1 partition), it could be that your disk is using dynamic (aka Logical Disk Manager, or LDM) partitions. In fact, this seems very likely, given that your screen shot identifies the disk as "dynamic." Linux can't install to such a disk. Some third-party tools can convert from dynamic/LDM to basic non-destructively, though. IIRC, both Partition Wizard and EaseUS Partition Master can do this, but I've never used either tool, so I can't comment on how well they work. Such operations carry a small risk of serious data loss, so I recommend backing up important data before proceeding.

If the screen shot you showed is deceptive, you may have a damaged partition table, which can confuse libparted (upon which the Ubuntu installer's partitioning features rely), resulting in an apparently-empty disk. This page covers this issue in detail. Such problems can sometimes be fixed by my FixParts utility.

  • Thanks! I wasn't able to use either of those tools to convert the drive to a basic one; other answers around the internet suggested I wouldn't be able to do this without losing data. For now I've decided to squish Ubuntu into the 8GB I could free up on my SSD; I'll see about backing up my data so I can move it into a roomier home in the future. Oct 6, 2013 at 0:21
  • Ohhhh. Okay. After getting Ubuntu up and working, it's unable to mound the second drive. Exited with status 12: failed to read last sector: invalid argument. One of the possible causes of the error is a corrupt partition table. That may be it, then. Oct 6, 2013 at 0:47
  • If you can boot to Linux (even an emergency disc) and show the output of sudo fdisk -l and sudo parted -l, that may be helpful. Either post the output on a pastebin site or (better) edit your original question and post the output there.
    – Rod Smith
    Oct 6, 2013 at 17:01
  • Okay, I've edited the question with those outputs, as well as the contents of the error message when I try to open the disk in Nautilus. Oct 6, 2013 at 23:01
  • You've got a dynamic disk/LDM setup on /dev/sdb. If you want to install Linux to the disk, AFAIK the only way is to convert back from that to a "basic" partition setup. At least one of the tools I cited should be able to do it. If you're having problems with that, I recommend you contact their tech support and/or post on a Windows forum.
    – Rod Smith
    Oct 6, 2013 at 23:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.