I' using Ubuntu 13.04. Two days ago I had a problem with the connectivity of the Wifi. I followed these instructions "...Now download the latest NetworkManager, in case you need to reinstall it if WICD doesn't work sudo apt-get install -d --reinstall network-manager network-manager-gnome

Then to install it sudo apt-get install wicd-gtk

And now you need to uninstall NetworkManager: sudo apt-get remove --purge network-manager-gnome network-manager.

Now you can find WICD in your menu Start WICD, find the network you want to use and enter the information needed, password, encryption, etcetera and choose Automatically Connect to this network. You should be good to go!"

But when I tried to connect to wicd: "Could not connect to wicd's D-Bus interface. Check the wicd log for error messages" and upon checking with System Testing Report I found this "Error:root: could not find def gateway info in /proc" and "Error:root: could not find default gateway by running route"

Lastly when I removed wicd-gtk and installed network-manager-gnome network-manager and tried to run "network" in the settings, it again says "The system network services are not compatible with this version"

Can you help?

1 Answer 1


OK, two possible solutions to the two parts of your problem.

Firstly, to get Network Manager back up try running this from the command line:

sudo service network-manager start

If that works, then you probably need to make that change permanent by editing the file /etc/rc.local and adding the line


before the line that says 'exit'. Reply if you need help doing that.

(See Restarted computer during update; "the system network service is not compatible with this version" for source of above.)

Secondly, if you want to try wicd again then it looks like you're experiencing a symptom of this bug: https://bugs.launchpad.net/ubuntu/+source/wicd/+bug/1132529

The solution that worked for me was to run the following commands from the command line (see comment #22 from above link):

sudo service wicd stop
rm /etc/resolv.conf
ln -s /run/resolvconf/resolv.conf
rm /var/lib/wicd/resolv.conf.orig
ln -s /run/resolvconf/resolv.conf /var/lib/wicd/resolv.conf.orig
sudo service wicd start

Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.