0

Ok. I have read through probably two-dozen posts and articles, and still can't seem to find an answer. I have installed OpenJDK-7 and am trying to set it as the default to open .jar files (specifically, I'm trying to set it as the default for minecraft.jar, freshly downloaded from the minecraft.org site).

I am running the 64-bit version of Ubuntu 13.04 (fresh install), and installed OpenJDK through the Software Center. Everything looks to be fine, OpenJDK shows up in the /usr/share/applications directory. If I right-click on minecraft.jar I see "OpenJDK Java 7 Runtime" as an option under the "Open With" context menu. That's fine. It launches the minecraft launcher, checks for updates, and I can fire up the game. The problem is, if I go to "Properties" and then to the "Open With" tab, OpenJDK is nowhere to be found in the list of options. I want to set it up as the default for .jar files so I can set up a launcher to drop into the unity launcher.

I have also used gedit in a terminal window to change the "defaults.list" file in the /applications directory to use openjdk-7-java.desktop for both jar and java-archive.

No matter what I try, the outcome is always the same: I can launch it if I right-click > open with > OpenJDK... but I cannot set OpenJDK as the default for .jar files.

0

I don't know how to add the option in the tab of the Open With menu. But to create a shortcut for the dash, you can use the alacarte application.

enter image description here

Then, you could drag-and-drop the shorcut to add it to your main menu.

0

If You have Ubuntu Tweak, you can create asociation in card File Types Manager Select line "Archive Java" and change the record by double click: Add > Use own command > type "/usr/bin/java -jar " and press enter. After that you can easily run java app by double-clicking on it.

Happy clicking!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.