I just installed ubuntu 13.04 on my HP pavilion dv2000 and it won't recognize my DVD drive. I know very little about computers. Can anybody walk me through figuring this out? I originally installed Ubuntu 12.04 with the DVD drive. I'm not sure if it recognized the drive after installation but it didn't work after I upgraded to 13.04. I reinstalled 13.04 to see if that would fix it and it didn't. Any other ideas?

  • normally dvd drive is automatically installed when installing Ubuntu. It could be a problem to read your DVD disk, and not a DVD drive installation problem. Could you edit your question to explain what happens when your insert a DVD disk in your DVD drive.
    – Boris
    Commented Oct 5, 2013 at 7:20

3 Answers 3


In a shell (Ctrl+Alt+T to open one) type:

sudo lshw -C disk

This should show you all disk devices including DVD/CDROM drives. They will be noted with their logical names included.

lshw should be installed, but sudo apt-get install lshw will install it if it's not.


Welcome to the Linux community. Here's a link to the official documentation to help with everything Ubuntu Desktop 13.04:

CD/DVD drives need to be mounted to work in Ubuntu (same for hard drives and mice). You can do this from Terminal (typing commands) or using Disk Utility (point and click). To get it you can open the Unity Dash (it's the button with the Ubuntu logo on the upper left), and type Disk Utility. My CD/DVD drive shows up at the bottom left.

To mount a cd/cdrom/dvd manually, you should first look in the directory /dev. Enter this in Terminal:

ls /dev

It might be called dvd, dvdrw, cdrom, or cdrw (mine has all 4). Next, create a directory for what you want to mount:

sudo mkdir /mnt/dvdrw

Finally, mount it by entering:

sudo mount /dev/dvdrw /mnt/dvdrw

Another helpful tool are the manual pages. To see them for the mount command you would enter (same way for any command):

man mount

Although the question is 2 years old at this time, this answer is provided for completeness.

In my experience, this was a hardware issue. Physically changing the SATA port on the motherboard to which the DVD drive was connected solved this issue, namely, an Ubuntu release upgrade causing a previously working DVD drive to fail to be recognized in the new installation. I do not presently know if this is due to Ubuntu not recognizing the device properly due to some bug, or if it's a fault in my motherboard.

More detail: I recently upgraded (to 16.04 from 14.04) and faced a similar problem: a previously working DVD drive stopped working. The DVD SATA cable happened to be connected to the SATA05 port on my motherboard. This worked fine in 14.04. After upgrading, it stopped working, and I fixed the problem by:

  1. shutting down my machine (don't forget to unplug it and then tap the power button once to discharge components, preventing electrostatic shock to yourself and damage to your machine)
  2. physically moving the DVD SATA cable to a different SATA port, preferably with a lower number (SATA01 in my case), if one is available.
  3. rebooting (don't forget to re-plug in the power cable)
  4. Enter the BIOS setup (usually by tapping F2 or F1 during boot on most PCs. Look at the screen during boot and it may make a recommendation, or Google it on another machine, referencing your computer brand & model, if you can't figure out the key on your own) and make sure the new SATA port that you just used for the DVD drive is enabled or "on."

After this procedure, my DVD drive worked perfectly in the new installation, including being automatically mounted and visible in the desktop environment.

Note: upgrading from a LTS release to a non-LTS release, such as from 12.04 LTS to 13.04, as the OP did, instead of going between LTS releases, carries a higher risk of bugs and associated troubleshooting.

  • This was more likely a bios issue than a dvd issue. I have 16.04 and my dvdrw is plugged into sata5 port, with no problems for the drive per se. I can play most dvds. But I cannot play Chinese dvd, and the o/s does not recognise the dvd: gives error no disk found. This is a problem for codec, libs, app, region, whatever. If anyone has a solution, please share.
    – rob grune
    Commented May 15, 2016 at 1:28
  • I had exactly this problem after an Ubuntu 16.04 upgrade. Previously flawless BDROM stopped being recognised at all, despite appearing in the BIOS - I even installed from this drive. It wasn't listed in dmesg, lshw anything. @Quest - thanks a bunch .
    – Kingsley
    Commented Mar 11, 2017 at 19:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .