0

I'm running 13.04 (64-bit version) but my webcam (Microsoft Lifecam NX-3000) stopped working when I upgraded. I downloaded the 32-bit drivers which fixed it for a while but now it's not recognised in Skype, Cheese or VLC.

Here's the output of lsusb:

Bus 001 Device 002: ID 045e:0721 Microsoft Corp. LifeCam NX-3000 (UVC-compliant)

And here's dmesg | grep uvcvideo:

[   16.552513] uvcvideo: Found UVC 1.00 device Microsoft LifeCam NX-3000 (045e:0721)
[   16.553854] uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
[   16.554225] uvcvideo: Failed to query (129) UVC probe control : -32 (exp. 26).
[   16.554234] uvcvideo: Failed to initialize the device (-5).
[   16.554996] usbcore: registered new interface driver uvcvideo
1

I got mine working as follows in (13.10):

echo 'options uvcvideo quirks=0x100' | sudo tee -a /etc/modprobe.d/uvcvideo.conf

www.linux-hardware-guide.com

  • Thanks, this worked with my USB microscope on Ubuntu 16.04. I ran your command, followed by: sudo rmmod uvcvideo; sudo modprobe uvcvideo – ketil Sep 16 '17 at 20:39
0

please reload the uvcvideo again and look if makes a different:

sudo rmmod uvcvideo
sudo modprobe uvcvideo

Regards, Torsten

  • Thanks Torsten, I've tried this but I still get similar results from dmesg (as above but repeated three times). I have managed to get the camera to work however by simply using a different usb port - I'll see if it fixes it permanently. – andylondon Oct 4 '13 at 12:29
  • Looks like this was a temporary fix. I had to restart and it's not working again. At startup I get an error message saying: [ 14.350290] uvcvideo: Failed to query .(129) UVC probe control : -32 (exp. 26) [ 14.350298] uvcvideo: Failed to initialize the device (-5). I'd be very grateful for any ideas on how I might solve this? Andy – andylondon Oct 4 '13 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.