I have recently installed Ubuntu 13.04 in my PC. Everything works fine except my Airtel 4G LTE dongle (Model MF825A). Ubuntu does not give any option to select 4G LTE when setting up a mobile broadband connection.

How can Airtel 4G LTE (Model MF825A) dongle be used with Ubuntu? Are there any patches or other updates available for getting this problem solved?


I spent 1 month figuring out this. Finally found it. It uses a relatively new method to connect to internet. Check my blog post http://krblogs.com/post/62519969772/airtel-4g-lte-on-linux

Create a HTML page:

<form action = "" method = "post">
 <input type="checkbox" name="goformId" value="CONNECT_NETWORK" checked style="display:none;">
 <BUTTON name="submit" type="submit"> Connect </BUTTON>

<form action = "" method = "post">
 <input type="checkbox" name="goformId" value="DISCONNECT_NETWORK" checked style="display:none;">
 <BUTTON name="submit" type="submit"> Disconnect </BUTTON>

You are ready to connect


As of February 11, 2014, there is no problem at all. I have Ubuntu 13.04 (in one partition) with the latest updates and it's very simple and easy to connect. Just plugin the Airtel 4G LTE dongle and click on the network manager icon in the panel at top right. You should see the modem detected and an option to connect to new mobile broadband network under the Mobile Broadband section. Click on it and follow through the prompts. Select India, Airtel and airtelgprs.com, click finish and you are done.

I cannot recreate the screen-shot as my connection is setup now, but the screen-shot below will give you an idea of where to go.

Airtel 4G LTE connected

Note: Do not use the connection manager from Airtel. It has security issues. If the connection manager is already installed, open terminal and uninstall it as below:

sudo su
cd /usr/local/airtel


You may want to check on the model of your Airtel 4G LTE dongle and search for its drivers that are specifically made for Ubuntu.

If your modem model is the Huawei E392, there is a known bug on Ubuntu that stops it from working properly. See Here...

protected by Community Jan 21 '14 at 19:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.