For several weeks, I've been having trouble with software-center under Ubuntu 13.04. It crashes silently, just a few seconds after execution. After each crash, syslog records a cryptic error:

Oct  3 23:14:11 mattbuntu kernel: [24085.941708] traps: software-center[20640] trap int3 ip:7f9ac3880135 sp:7fffaf98bf60 error:0

Software-center emits the following error when executed from the terminal:


** (software-center:4114): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-QORifKNTUU: Connection refused
2013-10-04 18:18:21,219 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2013-10-04 18:18:21,991 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2013-10-04 18:18:22,001 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2013-10-04 18:18:22,000 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-10-04 18:18:22,062 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2013-10-04 18:18:25,068 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/utils.py', 271, 'get_title_from_html')'
2013-10-04 18:18:25,068 - root - WARNING - failed to parse: '<div style="background-color: #161513; width:1680px; height:200px;">
 <div style="background: url('/site_media/exhibits/2013/09/AAMFP_Leaderboard_700x200_1.jpg') top left no-repeat; width:700px; height:200px;"></div>
</div>' ('ascii' codec can't encode character u'\xa0' in position 70: ordinal not in range(128))
2013-10-04 18:18:25,069 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'amnesia-amfp'' not available
2013-10-04 18:18:25,070 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'wakfu'' not available

(software-center:4114): Gdk-ERROR **: The program 'software-center' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 2575 error_code 9 request_code 62 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)

I have tried reinstalling the package, but that did not work. Any help will be appreciated.

  • 1
    Does the Software Updater crash as well? Did you upgrade to 13.04, or was it a clean install? Also, could you run software-center from Terminal and give us the full error? This well help us diagnose your problem.
    – Dillmo
    Oct 4, 2013 at 10:40
  • Hi Dillmo. It was a clean install. Software updater works great. The full error is here: paste.ubuntu.com/6194248
    – MattY
    Oct 4, 2013 at 22:22

1 Answer 1


This is an error in software-center. The bug report is here.

To fix the issue, you must patch the bug yourself:

  • open /usr/share/software-center/softwarecenter/ui/gtk3/views/lobbyview.py
  • add a # before the line self.exhibit_banner.set_exhibits([FeaturedExhibit()])
  • restart software-center
  • This solution worked perfectly for me. For context, I was messing with themes and Gnome Shell skins before encountering this error. I'm posting this comment in hopes that anyone else with issues after theme changes will see this indexed on Google.
    – Harsha K
    Jan 17, 2014 at 8:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .