My computer parts:

  • Gigabyte Z77X-D3H Rev1.1
  • Intel i5-3570k
  • Geforce GTX 660/iGPU
  • Corsair LP 8GB RAM

A few days ago, after I had installed a new BIOS, my Ubuntu install just stopped booting. It would start, but then stop after a few rotations of the 'loading' circles. I thought I could just fix it by booting up a Live USB and running boot-repair, but on starting the Live USB, the same thing happened. I went into the BIOS and changed all the UEFI settings and made absolutely sure that UEFI was completely disabled, as per when I installed both Windows and Ubuntu. I tried re-flashing the BIOS and clearing the DMI data pool, removing the GPU and checking to see if it was a driver issue, checking every component that I could, even memorytesting even though Windows 7 still booted up correctly. I tried booting different OSes, such as Fedora and Ubuntu 12.10/13.04, and Debian, but the only OS that worked apart from Windows 7 was Ubuntu 10.04, but understandably (I think) I don't want it. I know it can't be the USB/HD/CDs I'm booting off as I tried many different devices and none worked with newer Linux kernels. I'm also pretty sure that its not GRUB, seeing as GRUB 2 is used in 10.04 as well as 12.04 etc. I'm not a total 'noob' with Ubuntu consoles but I'm still not good, so please try to keep the help simple. Thanks in advance.


I have finally found the issue: it was not a hardware issue or BIOS problem, but the UEFI options in the BIOS that prevented any new version of Linux stop booting, even if you chose the legacy boot option in the boot options. All I had to do was switch to 'Legacy ONLY' in the BIOS settings and they now boot. I still am stumped by why UEFI is supported by 10.04 and possibly other older distros.


If you can install Ubuntu 10.04, then install it. After installing it, just upgrade it to the latest distribution version. Try doing this on the terminal after successfully installing Ubuntu 10.04.

sudo apt-get install update-manager-core

Since Ubuntu 10.04 is an LTS release and I am assuming that you want to install the newest version, you need to edit the release-updates file to reflect the latest dist instead of the LTS (12.04.3) or you may skip this step if you want to use the LTS version.

sudo vi /etc/update-manager/release-upgrades

Change the line which shows prompt=lts to prompt=normal then upgrade the packages before you run a distribution upgrade.

sudo apt-get update && sudo apt-get upgrade & sudo apt-get autoremove

After everything finishes, issue the following command to the terminal to upgrade to the latest distribution.

sudo do-release-upgrade

It should do the trick. However, I am not sure if it is a hardware issue on your side which is causing Grub to act up. You may want to check with your Motherboard Manufacturer about your new BIOS.

| improve this answer | |
  • Thanks for the help, but it doesn't work whether I do 'lts' or 'normal' after the upgrade, it just doesn't boot. I'll be sending my motherboard back to the manufacturer. – Carkazone Oct 5 '13 at 10:14

See my edit in my question. Basically you need to completely disable UEFI and then disable other options that also might prevent Ubuntu from booting, such as Intel Rapid Start Technology.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.