0

I'm stumped.

On my system, software-center was crashing within 2 seconds of execution. I tried to resolve the issue by running:

sudo apt-get remove --purge software-center
sudo apt-get install software-center

Unfortunately, the install fails. I get this error:

sudo apt-get install software-centerReading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 software-center : Depends: python-gi (>= 3.4.0-1ubuntu0.1) but it is not going to be installed
                   Depends: python-gi-cairo but it is not going to be installed
                   Depends: python-aptdaemon (>= 0.40) but it is not going to be installed
                   Depends: python-aptdaemon.gtk3widgets but it is not going to be installed
                   Depends: oneconf (>= 0.2.6) but it is not going to be installed
                   Depends: python-oneconf (>= 0.3) but it is not going to be installed or
                            oneconf (< 0.3) but it is not going to be installed
                   Recommends: sessioninstaller but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

In desperation, I tried apt-get build-deps, but this also failed.

sudo apt-get build-dep python-gi python-gi-cairo python-aptdaemon.gtk3widgets oneconf python-oneconf oneconf sessioninstaller
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Picking 'pygobject' as source package instead of 'python-gi'
The following packages have unmet dependencies:
 libcairo2-dev : Depends: libfontconfig1-dev (>= 2.2.95) but it is not going to be installed
 libglib2.0-dev : Depends: libglib2.0-0 (= 2.36.0-1ubuntu2) but 2.36.3-0ubuntu1~raring1 is to be installed
                  Depends: libglib2.0-bin (= 2.36.0-1ubuntu2)
E: Build-dependencies for python-gi could not be satisfied.

Any ideas?

0

Try to install all dependencies first. Seems your dependencies have dependencies as well. Have you tried sudo apt-get install -f?

  • Good catch. I kept hammering at dependencies until apt gave me a fresh copy of software-center. Unfortunately, I'm back to my original problem. Software-center crashes silently. – MattY Oct 4 '13 at 2:51
  • Was your software center working properly? Did it just crash after an update or application has been installed? – Chester Oct 4 '13 at 6:35
  • Sadly, I do not know EXACTLY when it stopped working. The last task I performed in the software-center gui was the removal of geany. Software-center functioned properly for awhile after that. The problem may stem from an update, but I'm not sure how to verify that suspicion. – MattY Oct 4 '13 at 22:06
  • 1
    Fixed! askubuntu.com/questions/353449/… – MattY Oct 5 '13 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.