I have a laptop with Windows 8 installed and an external hard disk with Ubuntu 13.04 installed which I connect through USB. I have installed grub on my external hard drive. Previously I was able to boot from my external drive without any problem. But now when I boot, my external drive is not displayed in Boot Options menu. I have one ntfs partition on my external drive and windows detects it. So, my laptop or external drive does not have any hardware problem.

I tried to boot from my external hard drive on another computer which does not have UEFI or Windows 8. It has both Windows 7 and Ubuntu 13.04 as dual boot. When I first booted from external drive, I got grub rescue screen. I followed the procedure given on How to fix "error: unknown filesystem. grub rescue>. I was able to boot into Ubuntu, but it was showing '/boot/efi' is not ready. I skipped mounting it and it worked. I thought the issue is fixed. But when I connected to my laptop, again it was not getting detected in Boot Options menu.

What could be the problem and what is the solution for this?


First, /boot/efi is where Ubuntu mounts the EFI System Partition (ESP). Depending on how the disks were partitioned, the internal disk, external disk, or both could have ESPs. If you installed Ubuntu on Computer A and it set Computer A's ESP to mount at /boot/efi, then when you moved the disk to Computer B and tried to boot, it would of course be unable to locate Computer A's ESP, and so you'd get the error about being unable to mount /boot/efi. I can think of a number of workarounds for this, but the best one probably depends on your computers' disk configurations (including the shared external disk); however, if you're just booting on Computer B on a temporary basis to debug the problem, it might be best to leave it alone. If you need help fixing this problem, please post the output of sudo parted -l on both systems, with the external disk connected to at least one of them. (Use an emergency disk to boot Computer A, if necessary.)

As to your Computer A boot problems, this could be an issue of a firmware setting, so you should enter your firmware's setup utility and look for options related to boot devices. It's also possible that the Boot Repair utility could help; but I'd be a bit wary, since your setup is unusual and Boot Repair will make permanent changes to your boot setup -- changes that might help but also might make matters worse. (You'll need to launch Boot Repair from an emergency disc, should you decide to try it.) Another option is to use my rEFInd boot manager. You can use the CD-R or USB flash drive image for testing without making any changes to your hard disk. If it works, boot to Linux and install the Debian package version. This might be more reliable if you ensure that your internal hard disk's ESP is mounted at /boot/efi, rather than the ESP on your external disk (if it has one).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.