2

I was using openshot and blender to create some animated titles and it was working fine until openshot just started to cry out for blender for no apparent reason. The previews work fine, and some appear to be working. It seems like simple ones involving just text work but any that require 3D modelling do not work. Here's the error I get:

Blender, the free open source 3D content creation suite is required for this action (http://www.blender.org).

Please check the preferences in OpenShot and be sure the Blender executable is correct. This setting should be the path of the 'blender' executable on your computer. Also, please be sure that it is pointing to Blender version 2.62 or greater.

Blender Path: blender

Error Output: No frame was found in the output from Blender

But it was working fine from the same directory before. And it should be a compatible version, as I've got 2.66a installed.

The only thing I can think is that this started happening after Ubuntu (13.04 Raring Ringtail) updated some python files. I'm not sure what they were exactly, but I know there was an update involving Python which I know blender needs to function, so it could be a bug in the latest Python or blender being incompatible with it.

I can also open blender and use it just fine, but I haven't tried rendering anything in it yet because I don't know how to use it, so I'd have nothing to render!

Thanks in advance, let me know if you need any more information and/or logs (but I'm a complete Ubuntu noob, so I'll need some help if you do want any logs :P).

EDIT: Just read Openshot's blog and saw that 1.4.4 was released and available through their PPA. I tried installing that, but the problem hasn't gone away. Here's the PPA if you're interested:

sudo add-apt-repository ppa:openshot.developers/ppa
sudo apt-get update
sudo apt-get install openshot openshot-doc

Another edit: Figuring it was a problem with blender I downloaded the latest version (2.68a) which comes in a .tar.bz2 file which is supposed to be run like a portable application. After redirecting openshot's blender directory to the extracted files the problem still remains. Got it from this site:

http://www.blender.org/download/get-blender/

0

Found this on another site and it worked for me. Very simple solution! "I'm using Ubuntu 14.04.1 and needed to change the location of blender from the default of 'blender' to '/usr/bin/blender' since this is the path used to access blender. From a terminal screen type 'which blender' (omitting quotes) will display the path to the blender executable. Enter the entire output line including the / at the beginning into the Blender location line of preferences." Thanks to rdgreenlaw (rgreenlaw) at https://answers.launchpad.net/openshot/+question/249837

0

I had this problem also. It seems that Blender version 2.69-4ubuntu2 that is on the Ubuntu Software Center is not compatible at this time with Openshot 1.4.3-1.1 that is currently on the Software Center.

The solution for me was to download Blender version 2.62 from this site, expand it, place the files in a new folder I named blender1 in home, and then copy the executable file icon and paste it into the "Blender executable" box in the Openshot preferences. Now it works just fine!

0

You should to pass the entire path of the blender on preferences in openShot. In my case I do /usr/bin/blender. I'm using Ubuntu 14.04

0

Is a bug! Use Blender to edit the vídeo. You just need a find the button that chance the interface from "video editor".

-1

Taken from here. Open a terminal and run these commands:

 cd /usr/share/pyshared/openshot/blender/scripts/
 sudo cp -f dissolve.py dissolve-back.py
 sudo gedit /usr/share/pyshared/openshot/blender/scripts/dissolve.py

Now, find this line:

ActiveObjectText.modifiers['Remesh'].remove_disconnected_pieces=False 

And change it to:

 ActiveObjectText.modifiers['Remesh'].use_remove_disconnected = False

And this line:

ActiveObjectText.particle_systems['ParticleSystem'].settings.adaptive_subframes= True  

Should be changed to:

ActiveObjectText.particle_systems['ParticleSystem'].settings.use_adaptive_subframes= True

Save the file and exit.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.