When I try to run apt-get update I get the following error messages: I am using:

Distributor ID: Ubuntu
Description:    Ubuntu 11.04
Release:    11.04
Codename:   natty

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/natty-security/multiverse/binary-i386/Packages  404  Not Found [IP: 80]

E: Some index files failed to download. They have been ignored, or old ones used

I have tried few solutions:

  1. Like choose the best server from Ubuntu Software section : It was never able to select the best server as it gave error (Check your internet connection.) My internet is working fine and I am able to browse.

  2. sudo sed -i -e 's/archive.ubuntu.com\|security.ubuntu.com/old-releases.ubuntu.com/g' /etc/apt/sources.list

  3. sudo dpkg --configure -a

Nothing worked. I am not able to post the full error message as its not letting me post more than two links.


Natty no longer supported or gets updates. You need to change from the archive.ubuntu.com to the old-releases.ubuntu.com server, which is the intention of the sed command you mentioned (I have not had chance to confirm if that works or not). Open and replace all entries in the following file:

sudo gedit /etc/apt/sources.list

Then after run the update and upgrade commands as you would normally.

| improve this answer | |
  • Doesn't work for me. keep getting on old-releases WARNING:root:file 'oneiric.tar.gz.gpg' missing Failed to fetch Fetching the upgrade failed. There may be a network problem. Tried various mirrors, none wants to play ball upgrading natty to oneiric. – Marc May 22 '14 at 6:23
  • 6
    As of 2015 this doesn't work anymore. Sucks that ubuntu is such a clusterfuck of complexity that it can't sustain slightly older releases. Gonna try to convince my admin to switch to OpenBSD. – Mark Boulder Jun 5 '15 at 10:25
  • This [partially] worked for me with the "zesty" release. – iammilind Jun 7 '18 at 15:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.