1

When I want to install libqtcore4 or libqtgui4 or even libqt4-xml I got this text

maryam@maryam-MM061:~$ sudo apt-get install libqtcore4
[sudo] password for maryam: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libqtcore4 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 428 not upgraded.

I work with ubuntu 12.10 Thanks

3
  • In fact, what is your question? Or you just wanted to tell us that you get some text when you want to install something from terminal? ...We know about this. Oct 2, 2013 at 10:30
  • @Alvar I delete my answer, because I realized that does not respond to anything... there is no question. Oct 2, 2013 at 10:35
  • why do you have to be so mean? The OP is obviously new to Ubuntu and doesn't understand the terminal as good as we do.
    – Alvar
    Oct 2, 2013 at 10:35

2 Answers 2

8

The lines actually say that libqtcore4 is already installed and is the newest version.

But it also says that you have 428 updates to install. Open the update manage with update-manager or type sudo apt-get update && sudo apt-get dist-upgrade to upgrade your system. dist-upgrade installs new kernels and such it does not install a newer release of Ubuntu.

5
  • Thank alot. Is it possible to ask you something about VTK INSTALLATION?
    – user196345
    Oct 2, 2013 at 11:23
  • 1
    @user196345 Ask a new question if it's about something else, also accept my answer if it solved your question. thanks :)
    – Alvar
    Oct 2, 2013 at 11:25
  • As you said I'm new and very very unfamiliar with ubuntu. and my question. I have to install vtk5.10 on my ubuntu with the following options VTK_USE_GUISUPPORT; VTK_USE_QT;VTK_USE_QTCHARTS;VTK_USE_RENDERING
    – user196345
    Oct 2, 2013 at 11:31
  • VTK_USE_GUISUPPORT sounds like the best for you, but I've never used this package so this is just my guess.
    – Alvar
    Oct 2, 2013 at 11:43
  • As you said I'm new and very very unfamiliar with ubuntu. and my question.I find out that I can't ask my question. because it is very long. If it is possible for you please search "VTK INSTALLATION ERROR" in ASKUBUNTU. Thanks
    – user196345
    Oct 2, 2013 at 11:58
1

That means you already have the software/package installed on your computer.

Not the answer you're looking for? Browse other questions tagged or ask your own question.