1

So i've got this LAMP server running on ubuntu 12.04 with an SSL certificate installed. I've got the certificate and the .ca-bundle files in /etc/ssl/certs. The host file located in /etc/apache2/sites-available called "default-ssl" has the following options in it;

SSLCertificateFile /etc/ssl/certs/mydomain.crt
SSLCertificateKeyFile /etc/ssl/certs/mydomain.key
SSLCertificateChainFile /etc/ssl/certs/bundle.ca-bundle

However my browser still doens't reckonize the intermediate certificate located in the bundle.ca-bundle file.

Please help me!

UPDATE: Got it figured out; had to edit the file 000-default located in /etc/apache2/sites-enabled/ and point it to the bundle.ca-bundle file.

  • Step 2 on this page might help. – Luis Flores III Oct 1 '13 at 18:17
  • Hi there, thanks for your link. Got it figured out; had to edit the 000-default file in /etc/apache2/sites-enabled/ and point it to the bundle.ca-bundle file. – Martijn Oct 1 '13 at 18:31
  • Glad to hear you got it working. – Luis Flores III Oct 1 '13 at 18:41
  • Please make an answer of your solution. – guntbert Oct 1 '13 at 20:04
  • Yes, i have to wait 8 hours to make my own answer. Ill update it as soon as i can. – Martijn Oct 1 '13 at 20:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.