I had a little bit of a problem when I uninstalled Gnome3 from my laptop (made it slower), and packages might have uninstalled a few things that nautilus needed in that process. Now, when I click nautilus from Unity side bar, it doesn't do anything. I type nautilus in terminal, and this is what it outputs:

tommydrum@crazypeople-ubuntu:~$ nautilus
Could not register the application: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface `org.gtk.Actions' on object at path /org/gnome/Nautilus

When I right click nautilus from unity and click a subfolder, it works, but not when I type nautilus /home/tommydrum/Downloads. When I run nautilus as root, this happens (it does work, but this is output):

tommydrum@crazypeople-ubuntu:~$ sudo -i nautilus
[sudo] password for tommydrum: 

(nautilus:14182): Gtk-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Initializing nautilus-dropbox 1.4.0
Initializing nautilus-open-terminal extension

(opens now..) (then I close it, goes back to commandline)

Any ideas what package I could reinstall? Or what package I might have uninstalled by accident.

  • Well that running as root part may be irrelevant... not really a problem... sorry, but it would be nice if nautilus (for my user) worked like it should... – tommydrum Sep 30 '13 at 17:39

This problem is probably stemming from the fact that you uninstalled GNOME 3. I don't know what version of Ubuntu you are running, but I know in version 12.10 Ubuntu actually shipped with an older version of Nautilus than the most recent GNOME version.

Regardless, you must have switched Nautilus versions somewhere through the upgrade and some important files were lost

My best recommendation without fully understanding the system would be to simply purge and reinstall Nautilus.

This can be done with the following commands:

sudo killall nautilus - this will make sure you kill the Nautilus program before you start working with it.

sudo apt-get remove --purge nautilus - this will totally remove Nautilus and any residual config files.

sudo apt-get update - this will make sure your sources are recent.

sudo apt-get install nautilus - this will freshly install Nautilus again.


http://www.omgubuntu.co.uk/2012/08/ubuntu-12-10-will-ship-with-older-version-of-nautilus https://launchpad.net/ubuntu/+source/nautilus/1:3.5.90.really.3.4.2-0ubuntu1/+build/3739314

  • And I was on 13.04, sorry for not mentioning that. And right now I'm trying to learn system stuff like that, but it works now so it's fine – tommydrum Oct 2 '13 at 1:43
  • 1
    If it worked, care to give an upvote? – Rubens Mariuzzo Nov 22 '13 at 18:27
  • not enough reputation on askubuntu yet.. it will eventually happen and i will come back to it eventually. – tommydrum Feb 19 '14 at 5:30
  • This answer didn't work on: elementary OS 5.1 Hera – Ron de Jong Jan 13 '20 at 18:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.