I am trying to install Ubuntu 12.04.3 LTS (32 bit server) on an embedded computer that uses the Intel N2800 CPU and chipset. I know there is no video driver for this chipset, but I don't care because all I want is a text console (no X Windows).

The Ubuntu installation works and the resulting system can be booted. The problem is I have NO video at all when it boots (after installation is complete). I do see the GRUB boot menu during boot, but then as the Linux kernel boots the video goes black. There is no X windows or graphics-- I just want a plain old 640x480 text console with 24 lines x 80 columns.

I tried installing Ubuntu 12.04 with the "nomodeset" option (press F6 before installing Ubuntu and ticking the "nomodeset" install option). This did not help-- same behavior.

I think the problem may be that GRUB is going into a high-res mode (which works surprisingly) and then the kernel tries to control the graphics mode during boot, but it fails and the video goes black (no video signal).

I know the system boots successfully because I can plug in a USB keyboard and login and reboot the system (I can't see what I'm typing, but the system does reboot when I issue the command).

Any help is appreciated. Thanks in advance.


So, you didn't say whether you were attaching the monitor to a serial, USB, or VGA port. And, it matters. The problem sounds more like the 'console' is not going to the port the monitor is attached to.

If you think the monitor is attached to the correct port, try editing /etc/default/grub and uncomment the 'GRUB_GFXMODE=640x480' line and/or put in whatever resolution you want to run at.

If it is not the correct port, edit /boot/grub/grub.cfg and find the line that says (approximately) console=ttyS0 and replace with the device path to your console. If you do change this, you will need the link below to make sure you are running getty or mingetty on that port: https://help.ubuntu.com/community/SerialConsoleHowto

The N2800 has the "FDI" integrated graphics chip set built-in. Unless your monitor is pre-1987, it can do graphics, as well.

You also say 'there is no X windows or Graphics' - but, your hardware supports both X and graphics. Thus, we need to ask, did you or did you not install Unity desktop and/or an X server, with or without a desktop? Ubuntu generically tries to use X it can find if it.

  • The monitor is attached to an old style 15 pin VGA port. The monitor is an Asus ProArt 24" modern monitor-- I've tried about half a dozen other monitors with the same results. I want the console to go to the VGA port, which I assume is the default when you install Ubuntu 12.04. – deltamind106 Sep 30 '13 at 17:08
  • There is no graphical desktop. I installed 12.04 "SERVER" without any X windows or desktop. It is just the base system. I want to logon using the text console. In fact, if I pop the hard drive out of this computer and put the hard drive in a different computer, then everything works perfectly, including video. – deltamind106 Sep 30 '13 at 17:14
  • So, yes sounds like the console is going out another port, which is why VGA is black regardless of monitor. What path/device file is defined for console in your boot (grub) configuration? – Andrew Sep 30 '13 at 19:01
  • I'm not sure how to check the grub configuration for the path/device of the console. I've listed the contents of my /etc/default/grub file above. I don't see anything /boot/grub/grub.cfg that looks like a console configuration. – deltamind106 Sep 30 '13 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.