How can I upgrade to a higher scipy (say 0.8.0) with a minimum amount of dependency hell?

sudo apt-get install libatlas-base-dev gfortran python-pip


sudo pip install scipy

or, if you already have another version of scipy installed

sudo pip install --upgrade scipy

I dug around a bit (quite a bit actually). Initially I tried installing enthoughts python (EPD 7.0) it all looks nice and self-contained. Oddly enough though, one of the things I needed to run (spyder, check it out, brilliant IDE if your playing around with python in the natural sciences) would segfault. I wasn't able to find the problem (yet) so I had to move on.

Then I tried what I should have done in the first place, namely choosing newer debian packages - turns out the dependencies aren't as frightening as I thought: installed natty's numpy and scipy and so far, all seems to work.

sudo dpkg -i python-numpy_1.5.1-1ubuntu2_i386.deb
sudo dpkg -i python-scipy_0.8.0+dfsg1-1ubuntu1_i386.deb

with the result that

$ python -c 'import scipy; print(scipy.__version__)'
  • Good to know -- thanks for posting the complete solution.
    – belacqua
    Apr 17 '11 at 23:41

As found HERE:

sudo apt-get install python-pip
sudo pip install scipy
  sudo easy_install scipy

or sudo easy_install3 scipy

You may need to install python-setuptools or python3-setuptools first.

  • mh, but that only gets me what I have already: Searching for scipy Best match: scipy 0.7.0 Adding scipy 0.7.0 to easy-install.pth file
    – DrSAR
    Apr 15 '11 at 5:06
  • and if I force an upgrade: (sudo easy_install -U --dry-run scipy) I get a ValueError since the numpy requirement (>=1.4) is not satisfied (currently 1.3.0)
    – DrSAR
    Apr 15 '11 at 5:12
  • Sorry about that -- my system is happy with 0.9.0: Best match: scipy 0.9.0 Downloading ... md5=a37933c9e3c4fdf8d087624cd7dcb47d We seem to have different versions for dependencies....
    – belacqua
    Apr 15 '11 at 15:22
  • So you're on 10.04 but have more recent versions of scipy (and likely some other packages as well)? How did you get there - probably not through apt-getting them, did you?
    – DrSAR
    Apr 15 '11 at 18:10
  • I've built a few things from git/svn etc., unfortunately. I don't have a fresh install at the moment, but I'll see if I can reproduce when I get a chance.
    – belacqua
    Apr 15 '11 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.