2

I have a Lenovo Twist (laptop that converts to a tablet) Win 8 with a touchscreen. I've tried to load several versions of Linux and the problem I run into is the touchpad is not recognized. The touchscreen works but the touchpad isn't loaded when I go into control panel. I posted on a different forum and was told I should do a insmod psmouse but that did't work.

Any idea how I can load drivers for my touchpad?

1

This appears to be a BIOS issue. Other users have reported that versions prior to 1.53 seem unaffected by this issue, however if you simply use the touchscreen to initiate a restart, the touchpad will be recognized the second time. No one seems to have yet reported a good explanation for this.

Be careful flashing to earlier BIOS versions as it seems some critical fixes are also in place post-1.53. In my case, the 1.53 had a serious problem with my internal network adapter, and the Twist would not boot without first manually disconnecting it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.