I'm using Ubuntu 13.04 and I have ASUS X550V laptop. This is my rfkill list:

0: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: asus-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

Before you start going: Hey, just turn on your hardware switch, dummy... my hardware switch is Fn + F2 and it works perfectly fine on my Windows boot. But, on my Ubuntu boot it does nothing... All the other Fn + F_ combos work (turn off the touchpad, screen turn off, screen brightness, sound) and they give some kind of visual indicator when I press it.

My lshw log:

*-network DISABLED
                description: Wireless interface
                product: AR9485 Wireless Network Adapter
                vendor: Atheros Communications Inc.
                physical id: 0
                bus info: pci@0000:03:00.0
                logical name: wlan0
                version: 01
                serial: 24:0a:64:28:b4:25
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
                configuration: broadcast=yes driver=ath9k driverversion=3.8.0-19-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
                resources: irq:17 memory:f7900000-f797ffff memory:f7980000-f798ffff
  • Can you enable the wireless with: sudo rfkill unblock 2? – chili555 Sep 29 '13 at 19:02
  • @chili555 No, I can't. – ante.ceperic Sep 30 '13 at 5:22

Is the module asus_nb_wmi loaded? Check:

lsmod | grep asus

If so, please try a driver parameter:

sudo -i
echo "options asus_nb_wmi wapf=0" > /etc/modprobe.d/asus.conf

Reboot and see if the Fn+F2 behavior is changed.

If the above does not work, redo it again but replace asus_nb_wmi wapf=0 with asus_nb_wmi wapf=1, and if that does not work, replace it with asus_nb_wmi wapf=4 instead.

  • THANKS THANKS THANKS for preventing us from killing ourselves! – deivid Dec 2 '13 at 19:36
  • 2
    How can I upvote this more than once... say 1 trillion times? you really made my day shine! THANKS THANKS THANKS (BTW to me wapf=1 is the one that worked) – neurino Dec 26 '13 at 12:38
  • 1
    I have an ASUS X550C Laptop and wapf=1 worked for me (0 did not) – jshthornton May 22 '14 at 14:32
  • 1
    on 14.04 Gnome, confirmed "options asus_nb_wmi wapf=1" . Thanks!! – Sandeep Jul 16 '14 at 9:50
  • After 3 hours of digging, wapf=1 did it for my asus X550V running Debian. Cheers buddy! – Stanimir Stoyanov Jan 21 '16 at 19:39

I have the same computer and the same problem (none of the above worked for me), now this'll be funny, but here's what does. Once I accidentally suspended the computer instead of shutting it down and when I turned it on, the hard switch was somehow magically on. I always have to suspend it and turn on again and the wifi turns on. 13.10 is quite buggy in general, I keep getting kernel error reports all the time, libre office crashes, key combinations don't work, my numeric keybord doesn't work (hard switch too)... this is really the worst version of ubuntu I've ever had and I have absolutely no idea what to do about it. I'm a woman, which implies that I'm not an expert, though I've been using Ubuntu for 6 or 7 years, I'm just a fan. If anyone has any idea (other than waiting for 14.4), please share, because this is annoying as hell.

  • 1
    This is an interesting solution. It makes sense that this would work: apparently the case of resuming from suspend is handled separately (in hardware/firmware and/or in the OS) and works properly. As for what to do about your system instability, I recommend posting a separate question if you want feedback on this. But I'd suggest "downgrading" to 12.04 LTS, which will remain supported for another ~3/5 years. – Eliah Kagan Jan 20 '14 at 16:46
  • I "downgraded" to 12.04. after the first system update, guess what... the hardware switch for wifi stopped working again :) – Evil Fairy Feb 21 '14 at 13:17
  • When you updated your system, probably some package was updated to a newer version that contains a bug. If you can identify which package that is and what version introduced the bug, you may be able to submit a bug report that facilitates fixing the bug. I'm not sure which package it is but it could be the kernel and that is pretty easily tested, since you can boot older kernel from the GRUB menu (unless you've uninstalled or otherwise deleted them). Do any of the older 12.04 kernels (perhaps the oldest one, which you installed with) not have the problem? – Eliah Kagan Feb 26 '14 at 18:49

Always worked for me:

rfkill unblock all

Since this is one of the first results that pops up on google, I'd like to share what worked for me.

I tried blacklisting the asus, acer drivers...

I tried removing the battery out of the computer, unplugging it and pressing the power button to reset something as this seemed to work for some other people...

I tried resetting bios to default...

I tried installing generic drivers...

Nothing worked. Then I found this post: http://ubuntuforums.org/showthread.php?t=1884245&p=11483954#post11483954

What I did is set my network card to boot first in bios, then the hard drive containing ubuntu and it worked from the first try. I don't know if all those other previous blacklisting and other steps helped, but this was the last straw that did it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.