11

Just installed 13.10, and the one of the first things i always do in a new install, is to disable capslock. But i can't find the keyboard options anymore?

  • Ubuntu 13.10 is not yet released so for now at least the question is off topic. You may want to ask on Ubuntu Forums: Ubuntu +1 or report it as a bug on Launchpad – Warren Hill Sep 29 '13 at 7:58
  • @WarrenHill: Please have a look at this: meta.askubuntu.com/questions/7363/… – jobin Sep 29 '13 at 10:25
  • @Jobin: It clearly states here that this site is not the right place for questions questions about issues with alpha and beta releases. – Warren Hill Sep 29 '13 at 10:35
  • 13.10 has now been released, and this is still an issue. Should someone vote to reopen it, or is it still off topic for something else? – Leif Andersen Feb 7 '14 at 4:58
7

I created an Autostart with the command

setxkbmap -option caps:none

Startup Applications > Add > Name: Disable Capslock > Command: setxkbmap -option caps:none > Add.

Restart and capslock is disabled. Works also in Ubuntu 14.04

  • Thanks a bunch! This is pure gold, for more than one reason. Can all or most commands be run like this? – mote Sep 24 '14 at 9:28
  • 1
    @mote: I guess you can run many commands via startup applications. E.g. I use a startup application to delete all thumbnails (command: rm -r /home/<username>/.cache/thumbnails). Just try. A more professional way is to define cronejobs, but I'm just an ordinary user. – MC Basstard Sep 24 '14 at 15:30
10

The graphical options for keyboard layout seem to have changed. You can do it via terminal though. Open a terminal using Ctrl+Alt+t and then do then:

setxkbmap -option caps:none

To re-enable them:

setxkbmap -option

To make this happen at every reboot, write the command to a file and store it in a convinient location(the filesystem should be ext4 where you would store the file) and then on a terminal, type crontab -e and then add this line to the end of the file that opens up(it may ask you to set the editor by which it should open, I prefer nano or vim.full:

@reboot /path/to/the/script
  • How can i make this permanent? - I guess i need some help making a script and running it at login. Thanks – mote Oct 9 '13 at 6:46
  • 1
    @mote: edited my answer, please have a look. – jobin Oct 9 '13 at 13:52
  • 1
    You can look at a list of other options at in /usr/share/X11/xkb/rules/base.lst – Ehtesh Choudhury Feb 18 '14 at 20:58
  • setxkbmap -option caps:none not working (Lubuntu 13.04). – Vitaly Zdanevich May 3 '14 at 12:59
  • @VitalyZdanevich: 13.04 is no more supported. – jobin May 3 '14 at 13:10
0

This one works without restart everytime:

setxkbmap -layout us -option caps:ctrl_modifier gsettings set

org.gnome.desktop.input-sources xkb-options "['caps:ctrl_modifier']"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.