2

I'm running 12.04 LTS, and as usual when the package manager prompts me to update I do it. I updated last night (Sept. 27) and now the system boots only into command line mode.

Before doing so I see the purple screen with the words "ubuntu 12.04" and the little dots going bright and dark, and then bam I'm in command line. I've tried using sudo apt-get to update my files, in case it was incomplete, and it tells me that everything is up to date. If I type the command "unity" I get a "fatal error" related to "no display variable set".

I have seen other questions and answers on this topic but I do not understand the answers provided. I am stuck. All I did was upgrade when the system told me to, what did I do wrong? I did not download any new video drivers lately.

  • What does sudo startx say? – tjons Sep 28 '13 at 17:10
  • What happens if you log in and launch sudo service lightdm restart? – gniourf_gniourf Sep 28 '13 at 17:27
  • sudo startx produces an error stating that the "NVIDIA kernel module has version 319.32, but this NVIDIA driver component has version 304.88" and urges me to ensure that they match. I do not know how to do this without a desktop and a browser I can launch to go to the NVIDIA website, and I'm not sure what graphics card model I have. – Bill Sherman Sep 29 '13 at 3:27
  • 'sudo service lightdm restart' produces several messages about "skipping profiles", "speech dispatcher disabled", "starting winbind", "saved disabled" and finally "checking battery state...", at which point it seems to stop. – Bill Sherman Sep 29 '13 at 3:29
  • I found the entry askubuntu.com/questions/37590/…, and followed its instructions, and now I cannot boot to terminal either. I get a (low-res) version of my usual graphical login screen, I enter my password, the screen flickers and redraws itself, and I'm back at the login screen. I have tried entering recovery mode but I can't. All I can get now is a desktop/UI login screen that sends me back to itself. – Bill Sherman Sep 30 '13 at 15:05
1

Thanks everyone. Using Ctrl-Alt-F1 to get to a TTY, I was able to run various apt-get commands to purge and reinstall my drivers completely, as seen in similar questions here on the site. My login credentials were broken as well so deleting my .Xauthority file allowed it to refresh and I'm OK now.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.