My laptop won't boot Natty beta 2 unless it is plugged in most of the time (like 2 out of 3 times). After it is booted I am able to unplug it and let it run on battery power with no problems. Sometimes I will be able to boot on just battery power, other times it will hang at either a blank, purple screen right after grub2 or at the flashing "_" screen.

My laptop is a Lenovo Y460.

  • Another interesting thing is that it will only have this problem on the new 2.6.38-8 linux kernel, natty will boot normally on the 2.6.35-22 kernel (i have both because it was an upgrade from 10.10.
    – user14274
    Apr 14, 2011 at 20:27
  • possible duplicate of Lenovo Y460 Shutdown/Reboot/Logoff doesn't work
    – fossfreedom
    Jul 5, 2011 at 21:39
  • i had the same problem .in my situation it was because of dual booting with windows seven .when i installed the ubunutu without win 7 the problem had solved
    – user78180
    Jul 20, 2012 at 9:04

1 Answer 1


I have the Y560 and am experiencing the same problem. I tried downgrading to older kernels but still have the same issue. I did find this bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/775950 and verified that I have the same kernel panic and message happening. There is also someone with a Y560 with the same problem here Lenovo Y560 won't boot unless it's on AC power

  • It appears that the latest kernel update (2.6.38-10-generic) has fixed the issue on the Y560. In the bug report posted above it does seem that some people are still having issues with other things but you may try and see if it works.
    – user16286
    Jul 16, 2011 at 3:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .