I've just bought a TV/monitor and when is connected to my laptop by DP output nothing happens. It only shows a log saying "There is no signal coming from your computer". The same for the HDMI output.

Maybe it is a problem with drivers. I do not know. I wish somebody could help. Thanks.

I attach the following logs:

rbaena@fajnmp2:~$ uname -a
Linux fajnmp2 3.2.0-38-generic #61-Ubuntu SMP Tue Feb 19 12:18:21 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

rbaena@fajnmp2:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.3 LTS
Release: 12.04
Codename: precise

rbaena@fajnmp2:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
1920x1080 60.0*+ 59.9 40.0
1680x1050 60.0 59.9
1600x1024 60.2
1400x1050 60.0
1280x1024 60.0
1440x900 59.9
1280x960 60.0
1360x768 59.8 60.0
1152x864 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9
VGA1 disconnected (normal left inverted right x axis y axis)

rbaena@fajnmp2:~$ sudo lshw -C display
*-display UNCLAIMED
description: VGA compatible controller
product: GK107GLM [Quadro K1000M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:f5000000-f5ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f6000000-f607ffff
description: VGA compatible controller
product: 3rd Gen Core processor Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:46 memory:f6400000-f67fffff memory:d0000000-dfffffff ioport:f000(size=64) 

If I am not mistaken the HDMI port is being controlled by the NVidia graphics card.In order to make it work you have to activate the NVidia card only and disable the Intel card from the BIOS.There must be something that it will give you three option about the Display in the BIOS.One of them is Optimus,another is Integrated Graphics and the final one is Discrete graphics.

If you haven't changed it since the day you bought the laptop then it is probably running on Optimus mode.Optimus technology is not supported very well in Linux distributions in general.

Unless of course there is a way to do it using bumblebee or newer drivers from NVidia which might bring better support


I tried to do the same thing on my laptop and I messed it up really bad.Because NVidia graphics card have their own XSERVER when you boot using only the NVidia graphics card it might change the XSERVER settings and when you you wish to run again on Optimus mode under Ubuntu it might be impossible.This is what happened to me and I had to reinstall Ubuntu,because It didn't know how to fix it.

I suggest you also to wait for other responses of other members as well.It is certain that there are people here who know better than me.

  • Thanks for your answer. Why did you want to move back to Optimus mode after enabling only the nvidia card? Did you miss at some point control over the laptop screen? – roberto Sep 28 '13 at 13:54
  • Following your comment I accessed the BIOS and checked that Optimus mode is indeed enabled. There is a text warning this mode should be only valid for Windows 7 32/64 bits and not applied for other OS. Anyway, I do not want to touch this after your warning and will wait for other responses. – roberto Sep 28 '13 at 15:50
  • I wanted to go back to Optimus mode because when the Discrete graphics are enabled the laptop runs out of battery quicker than usual.Plus I usually use my video card for compiling purposes only and Opimus mode does the job for me under Linux. – und3rd06012 Sep 28 '13 at 16:42
  • Once you disabled the Optimus mode and started using the Nvidia card, did you experience any trouble with your laptop screen, e.g., blinking, lose of resolution, etc, etc? Thanks – roberto Sep 30 '13 at 8:10
  • First,I had the wrong resolution on grub.It's like it lost its settings.Second,when it booted to Ubuntu the resolution was the right one but when I tried to apply changes from the NVIDIA'S XSERVER settings program things got ugly.Not only the settings didn't apply,but aslo Ubuntu froze and when I restarted all I was able to see was a blank screen.And when I tried to go back to Optimus mode it was impossible.PLEASE NOTE THAT I DIDN'T CHANGED ANY SETTINGS ON THE NVIDIA'S XSERVER SETTINGS WHICH HAD A WARNNG THAT IT NIGHT MESS UP THE OS. – und3rd06012 Oct 2 '13 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.