0

I enjoyed using Ubuntu for the past few weeks and decided to uninstall Uindows using the "OS-Uninstaller Graphical Tool". Now I get the error bootmgr is missing. When I try to use the DVD from the Boot Menu, it shows

kernel panic - not syncing : VFS: Unable to mount root fs on unknown-block(2,0)

I'm new to Linux and any help is greatly appreciated.

0

Sounds like something went awry with your uninstall! ;)

My guess is that when you uninstalled Windows, it took part of Grub (Ubuntu's default Bootloader) with it. I've ran into similar issues, though I'm not sure it's exactly the same.

To fix my issues when I lost my bootloader, I started up a LiveCD/USB and then chrooted into my HDD installation of Ubuntu. From there, I ran update-grub and from that point on, it worked fine again.

The Accepted Answer Here Gives a Step By Step Explanation of the Above.

== Another Thought ==

It's also possible that when you uninstalled Windows, some configurations with grub needed changed, ie the sector that it boots from ( hd(0,1) etc ).

9
  • Thanks for responding! However, using the live CD/USB is how it goes into the kernel panic. Therefore I can't get past step 1 of the instructions linked. Solutions I've found online don't involve both the bootmgr and kernel panic. – Bjorn Sep 28 '13 at 2:56
  • lol, that doesn't make a ton of sense to me. Using the LiveUSB, it shouldn't panic. Are you 100% sure that it's not instead going straight to the HDD, thus bypassing booting the LiveUSB? – Goldentoa11 Sep 28 '13 at 2:58
  • I've even selected the CD/DVD drive (I've tried usb and dvd by this point) in the boot menu. Both ways I get the same kernel panic. – Bjorn Sep 28 '13 at 3:01
  • When you say "boot menu", are you referencing a purple screen that has entries like "Ubuntu", "MemTest86+", etc, or a black screen that says "HDD", "CD/DVD", "USB", "Network"? – Goldentoa11 Sep 28 '13 at 3:03
  • The black screen, it then kernel panics or goes to the purple screen. From the purple screen I've tried "try ubuntu w/o install" and actually installing, both of which end in a kernel panic. – Bjorn Sep 28 '13 at 3:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.