I cannot launch FireFox, as I'm getting the "Your Firefox profile cannot be loaded. It may be missing or inaccessible." error when I attempt to launch the latest FireFox in Ubuntu 13.04 (up to date). Bash produces the following:

(process:5052): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
Error: Access was denied while trying to open files in your profile directory.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.

I do not think this is a duplicate question, as I have tried the 3 solutions that are posted in one place or another. Here they are:

(1) Remove and reinstall FF. Attempting to launch produces the same error.

(2) Rename /home/[myname]/.mozilla from bash, then create a new folder to replace it, so as to make sure that the correct user owns the directory. Attempting to launch produces the same error, both in Unity and in terminal.

(3) chown the directory from bash, with

sudo chown myname /home/myname/.mozilla

or with

sudo chown myname:myname /home/myname/.mozilla

The command executes without problems, but launching FF produces exactly the same error as before. When I check the owner of the folder, it shows the correct user (me). Recursively setting ALL permissions to 777 (so there can't be a problem with the permissions still gives the same thing.

I can run 'sudo firefox' from bash. But bash throws a warning that the profile folder has the wrong owner (i.e., it's not owned by root).

So, any ideas?


Complete purge removal via

sudo apt-get purge firefox firefox-globalmenu firefox-gnome-support

and reinstall with

sudo apt-get install firefox firefox-globalmenu firefox-gnome-support

Also does not work. Exactly the same behavior as before.


This seems to a known, system-dependent bug. Have a look at the link added at end (your precise error message). Following another link on that page, only suggestions I saw were to disable AppArmor if you run it; or roll FF back: Bug Report.

If nothing works, maybe give Chrome a try.

  • I'm primarily a Chrome user, but as a web developer I need to have FireFox working too, if only for testing. – Jeff McMahan Sep 28 '13 at 15:24
  • That sucks, as it really sounds it is bug based on the combination of your system with current FF. I would try to get a tarball of a slightly older version of FF then, and see if that version works. Not ideal, but better than nothing. Gl! – gnometorule Sep 28 '13 at 16:55

Found the below link that is related.


I did the following:

ls .cache/mozilla/
   ls: cannot open directory .cache/mozilla/: Permission denied

chown -R user.user .cache/mozilla/
    chown: cannot read directory ‘.cache/mozilla/’: Permission denied

sudo chown -R user.user .cache/mozilla/

This fix my problem.

  • It works. But the absolute path is ~/.cache/mozilla/ The paths in the answer will only work if you are under ~/ oath (your home) – Jeflopo Mar 1 '15 at 16:29
  • that's just worked perfect.. but i had also done sudo chown -R usernamehere.usernamehere .mozilla/ now i can use firefox :) – Mohammed Sufian Oct 5 '15 at 19:52
  • I had run chrome with sudo, and with --no-sandbox, so I'm guessing that this is why Firefox then couldn't access the .cache directory properly. This answer got me going again, though. – Shafiq Jetha Jun 9 '19 at 7:31

You have to remove/gain access on 2 folders:


The .cache folder you can just delete :)

  • This worked perfectly. The originals as installed were owned by root. – LantzR Dec 25 '15 at 0:29

Error: Access was denied while trying to open files in your profile directory.

Sounds like you're running into a permission error, where firefox is not allowed to read/write/execute the profile directory. Could you try running (using sudo)

chmod ug+rw ~/.mozilla -Rf

and see if that fixes the issue?

What that will do is grant read and write permission recursively to the user and group of the hidden ~/.mozilla folder. You also may need to grant execute permission on the folders as that will allow you to traverse into the folders.

== UPDATE ==

Just read through the part where you mentioned you essentially have done this already.

Not the answer you're looking for? Browse other questions tagged or ask your own question.