4

If I search for the package "imagemagick" in http://packages.ubuntu.com/ it gives me the result and the word security written like this: [security]. Does it mean it is in the main repository?

Another result is that the package is also provided by graphicsmagick-imagemagick-compat which is in the universe repository. Does this mean that the same package is provided twice? Would it also be possible that when a package is installed but the respective repository is disabled as the source the needed package would be installed from ather repository?

4

The mark [security] means that the package comes from the security updates repository, rather than the main repository. The security updates repository is always enabled and you should never disable it. It contains packages that are identical to the original package from the main repository except that one or more security vulnerabilities have been fixed.

The same package is also provided in the <version>-updates repositories. These repositories contain bug fixes and other recommended updates. These updates are pushed in batches, unlike security updates which are released as soon as possible.

That the package imagemagick is also provided by graphicsmagick-imagemagick-compat is unrelated. Graphicsmagick is a software project that started as a modification of Imagemagick and then evolved independently. Graphicsmagick includes an interface that is compatible with Imagemagick; this interface is distributed in the package graphicsmagick-imagemagick-compat. If you have graphicsmagick-imagemagick-compat installed, then packages that depend on imagemagick will work, therefore the graphicsmagick-imagemagick-compat package declares that it provides imagemagick. You can choose which implementation you prefer.

Ubuntu will automatically install the most recent version of a package among the repositories that are enabled on your system (except for versions or repositories that are excluded from automatic installations through preferences — for example, backport repositories are set up so that you only get backported packages upon explicit request).

  • If anyone is curious about what these security updates are about just check the changelog – Braiam Sep 30 '13 at 13:44

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.