My question is about xterm menu colors, but perhaps I'm doing something else wrong so I'm going to include the background steps that got me to this question.

I'm trying to get XTerm to send escape by default when I hit the meta key. I can get this to work by adding a .Xresources file:

XTerm*metaSendsEscape: true

That works great, but by loading the .Xresources file it changes my new xterm color schemes to black on white; I want white on black.

Ok, I can fix this. I'll just add some more config to my .Xresources:

XTerm*Background: Black
XTerm*Foreground: White
XTerm*metaSendsEscape: true

This does set my xterm back to the color scheme I want. Almost. The background and foreground are both black, but now the menus (ctrl+left click) have the same color scheme which makes it hard to see them.

So I now want to change the menu colors independently of the normal background and foreground, but I can't figure out how to do that. I assume it is possible because if I remove the .Xresources file that is default that I get.

This is what my xterm looks like without a .Xresources file (this is what I'm trying to replicate using .Xresouces): xterm with correct colors

This is what my xterm currently looks like with the above .Xresources: xterm with black on black menus

1 Answer 1


You can try to add the "AntiqueWhite" color for the 3 menus (Main,VT Options & VT fonts).

1) Edit your .Xresources file with your favorite editor:

  • gedit ~/.Xresources

2) Add the following lines:

XTerm*mainMenu*Background: AntiqueWhite
XTerm*vtMenu*Background: AntiqueWhite
XTerm*fontMenu*Background: AntiqueWhite

3) Load the changes with the following command:

  • xrdb -merge ~/.Xresources

enter image description here

Hope it helps.

  • Or XTerm*SimpleMenu*Background: AntiqueWhite
    – gboffi
    Apr 13 at 8:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .