Using Ubuntu 10.10, gnome, and dual nvidia monitors.

Gnome panels and docky are able to "reserve" part of the screen for themselves in such a way as to prevent maximized windows from covering them up. I'd like to setup a region on my desktop in the same manner. Between conky, pidgin, pandora, and a couple of widgets, I have a group of items I want to always be able to view. "Always on Top" is not good enough,

I don't even know which part of the "stack" (X, Compix, Metacity, Gnome...) controls this behavior, and my google-fu was too weak to find the answer.


(Re-Post from Superuser.com, No answer over there in 2 days so I thought I'd give it a shot here.

2 Answers 2


Maximumize may be useful for that case instead of Maximize. Which is included in the CompizConfig Settings Manager and will "Maximumize windows (resize them to fit the available screenspace)"

In your case, Maximumize will fit the window's size in order to use the maximum available screen space in the active work space and this way, windows in screen containing the pidgin, conky, and other window-like applications will be dodged by the Maximumized window. I am not sure if this will act the same with docklets but you give it a try and please let us know.

Good luck!

BTW: You may need to set your own key bindings in order to make this work. I used [Alt]+M and it works fine for me.

enter image description here

enter image description here


I think I've discovered the canonical solution to this problem, which is almost the same as my question: Maximize windows to physical screen when using a virtual resolution w/xrandr (read my self-answer there; it explains more). The trick is to set up an intricate "output" system in Compiz.

If you use the Compiz configuration tool (described in my answer to that question) you simply want to set up two outputs: one of them equal to the exact resolution of your screen (or virtual desktop, as considered there), and the other one of the size and position you want to have windows in.

For example, if you have a 1024x768 screen and you only want windows to maximize into the 800x600 region in the upper left, you would put two outputs into Compiz' config box: "1024x768" and "800x600-224-168": the minus signs say that those offsets are measured from the bottom and right, rather than top and left. You also have to do the other things I say in that answer: disable autodetection of outputs and enable "prefer smaller output".

Then you place your widgets in the margin that lies only in the larger output (in the example, that 224px-high strip at the bottom or 168px-wide strip on the right) and open all your other windows into the smaller output; they will maximize just to the smaller region.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .