5

Alright, I have this problem where I installed two different versions of swi-prolog.

I manually installed swi-prolog (swipl) version 5.10.4 from a tar-file, which I see now is a stupid thing. (I can't remember why I did this exactly, but that is besides the point.)

Then I wanted to get the newest version of prolog, so I followed these steps:

sudo apt-add-repository ppa:swi-prolog/stable
sudo apt-get update
sudo apt-get install swi-prolog

Now if I do

swipl --version

I get

SWI-Prolog version 5.10.4 for x86_64-linux

And if I do

/usr/bin/swipl --version

I get

SWI-Prolog version 6.4.1 for amd64

I only want the 6.4.1 version on my computer.

I searched the internet for hours, but I couldn't find out how to solve the problem. (Maybe I've been searching for the wrong terms/tags, I don't know..)

So, I found out that the 5.10.4 version can be found at /usr/local/bin/ whereas the 6.4.1 version is at /usr/bin/. Can't I just rm the 5.10.4 version from /usr/local/bin/ then? Or is that not clean, e.g. does it leave obsolete files somewhere on disk?

I just deleted the file swipl at /usr/local/bin/swipl with the rm-command. Now I get the 6.4.1 version whenever I call swipl, but I still wonder if this is a good solution.

The output of type swipl is swipl is /usr/local/bin/swipl and the output of dpkg -S $(type swipl | awk '{print $3}') is dpkg-query: no path found matching pattern /usr/local/bin/swipl.

I untarred the .tar-file and I ran make from the source (src folder) that was in the .tar-file. Then installed the program using sudo make install.

  • 1
    I cannot remember for sure if I did, but I think I probably did sudo make install. – PJvG Oct 1 '13 at 14:14
2

To uninstall software installed with sudo make install the best way to remove them is using sudo make uninstall.

| improve this answer | |
  • I usually clean up my download directory after I download something. This was also the case with the .tar-file containing the source from which I ran make. I don't have the .tar-file anymore, but I'm sure I can find it to download it again. Do you suggest I should download the file again, untar it and then run sudo make uninstall? – PJvG Oct 1 '13 at 14:21
  • 1
    Yeah, but you must make ./configure and make first. Is all the same process just that at the end is uninstall. – Braiam Oct 1 '13 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.