6

I'd like to use unattended-upgrades to install all updates to Natty beta packages daily. Whatever I try, unattended-upgrades seems to ignore updates to packages in "main". Here's my current Allowed-Origins section of /etc/apt/apt.conf.d/50unattended-upgrades.

Unattended-Upgrade::Allowed-Origins {
    "${distro_id} stable";
    "${distro_id} ${distro_codename}-main";
    "${distro_id} ${distro_codename}-security";
    "${distro_id} ${distro_codename}-updates";
    "${distro_id} ${distro_codename}-universe";
    "${distro_id} ${distro_codename}-multiverse";
    "${distro_id} ${distro_codename}-restricted";
};

Update: Here's the working Allowed-Origins I came up with using the advice from the accepted answer:

Unattended-Upgrade::Allowed-Origins {
    "${distro_id} stable";
    "${distro_id} ${distro_codename}";
    "${distro_id} ${distro_codename}-main";
    "${distro_id} ${distro_codename}-security";
    "${distro_id} ${distro_codename}-updates";
};
4

There is no -main, -universe, -multiverse, or -restricted repository. Main, universe, etc are pockets within each repository. Packages from all pockets in an enabled repository are installed. There are only 4 repositories and they are all listed in that config file by default:

distro
distro-updates
distro-security
distro-proposed-updates

By default both updates and proposed-updates are commented out. Simply uncomment the -updates line if you want all updates instead of only security related ones.

  • Thanks! I already had "${distro_id} ${distro_codename}-updates" in there but I was missing plain old "${distro_id} ${distro_codename}". I added that and now I'm getting all the updates. – Ben Williams Apr 15 '11 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.