8

How I can replace **notification-daemon** (ugly notifications at bottom of screen) by

NotifyOSD (modern bubbles in right upper corner) ?

I found some posts about this, but GNOME at default mode don't have Default Provider in

gnome.session (only in fall-back mode).

10

The information this post provides is related:
How can I make clicking Notify-OSD notifications bring me to their application/message?

The system file (12.04):

file:///usr/share/dbus-1/services/org.freedesktop.Notifications.service  

contents are:

    [D-BUS Service]
    Name=org.freedesktop.Notifications
    Exec=/bin/sh -c 'if
         [ ! -x /usr/lib/notification-daemon/notification-daemon ] ||
         [ "$GDMSESSION" = guest-restricted ] ||
         [ "$GDMSESSION" = gnome-classic-guest-restricted ]
         [ "$GDMSESSION" = default -a
              "$(basename `readlink /etc/alternatives/x-session-manager`)" =
                    gnome-session ] ||
         [ "$GDMSESSION" = ubuntu ] ||
         [ "$GDMSESSION" = ubuntu-2d ];
      then exec /usr/lib/notify-osd/notify-osd;
      else exec /usr/lib/notification-daemon/notification-daemon; fi'

presumably, switching the code segments that are bold will do the switch, but whether the change is actually functional is another matter. (for instance - Do both notification-daemon & notify-osd exist? etc.)

Another crude possibility is to rename the binaries swapping the names of notification-daemon and notify-osd however sometimes there are issues like conflicting dependencies occuring when a binary examines its own name.

I don't like posting hypothetical solutions but this is something I prefer not to try and since there has been no response perhaps this post will invigorate the audience and instigate better answers.

ref:

2

I use this trick on Ubuntu 13.10: just remove notification-deamon from startup applications:

Show start up services (hidden by default)

cd /etc/xdg/autostart/
sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' *.desktop

Open Startup Applications (System Tools -> Preferences -> Startup Applicazions), search for "Notification Deamon" and unable it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.