6

Using gedit 3, I've tried multiple plugins to highlight all instances of the current selection (a la Notepad++):

https://code.google.com/p/smart-highlighting-gedit/

https://github.com/mmuell23/mmuell23

The smart-highlighting will seem to install and let me activate it, but doesn't seem to actually do anything.

The one at github was written for v2. To try to hack it into v3, I've tried:

  • change .gedit-plugin to just .plugin
  • edit IAge=2 to read IAge=3

That one still won't load (doesn't appear in prefs->plugins list). Doesn't throw an error, just doesn't load. I also can't find the gedit logs anywhere to see if there's a helpful message (I'm relatively new to Linux). I checked /var/logs/ but there's no gedit.

Can anyone help? I just want the auto-highlighting to work.

4

You don't need any plugin to highlight all instances of a selection in gedit. Select the text about you are interested in, then just press Ctrl+F (to search all instances of that selected text):

gedit - highlight text


Now, let me give you some explanations about those plugins. First one, smart-highlighting is working like a charm for me. How I made:

Second plugin, it's for gedit2.x and finish. It's not enough a simple hack like you tried.

[UPDATE]

Only works if installed to ~/.local/share/gedit/plugins/. More in comments.

  • 1
    Thanks, but while that's true, it's not what I'm after. I'm after the functionality as advertised in the referenced plugins. I want to be able to select some text and have all matching instances be automatically highlighted. – Allen Sep 26 '13 at 17:35
  • Additionally, that highlighting (even as shown in your screenshot) is less useful as it takes a very lazy/naive approach and matches the "to" in "auto" as well as "to". – Allen Sep 27 '13 at 3:48
  • 1
    if you'd ever used Notepad++ on Windows, then my expectations would've been more...expected. :-) – Allen Sep 27 '13 at 14:43
  • 1
    @Allen Ah... I forgot to say this: just for me. – Radu Rădeanu Sep 27 '13 at 15:44
  • 1
    Installing for just me made it work. I noticed a "_" vs. "-" difference in the naming of the config folder (which was initially empty), so I removed the plugin from my home dir to go test the global installation (which I hadn't removed yet). But, even after closing and re-opening gedit, it still worked after removing the plugin from my home dir. I noticed that the config dir (in home dir by default) is now populated. Something weird about that, but I don't have time to investigate further. – Allen Sep 27 '13 at 15:55
1

I am using Ubuntu 19.04, gedit 3.32 and gedit-plugins which have plugin "Quick highlight":

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 19.04
Release:    19.04
Codename:   disco

$ gedit --version
gedit - Version 3.32.0

sudo apt install gedit-plugins

and then manually enable it in Preferences - Plugins

enable gedit plugin

-1

This plugin does what you want, just follow the instructions in there: https://github.com/mmuell23/mmuell23

  • Please expand on your answer to include the directions referenced, as if the link ends up dead as a 404 the answer is of no use to anyone. If possible, try and reference the name of and instructions on how to install the plugin. – sbergeron Mar 10 '16 at 14:14
  • I think instructions themselves are useless without the actual plugin which is supposed to be available on the main site and not to be uploaded here. In addition, my instructions may become outdated after the author decides to change them anyhow. – Hack06 Mar 10 '16 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.