I have just purchased a new Asus ENGTS450 DirectCU graphics card, Geforce 450. My problem is that I can't get to my desktop with this new card. At first I just simply replaced my old Nvidia card with this new one, but booting freezes after the "staring up logo".

Then I added ubuntu-x-swat PPA and upgraded nvidia driver to version 270.41.03. I think it also upgraded X. But anyway, booting with the new card still freezes.

I'm running Ubuntu 10.10 with all packages updated.

Does anybody know if this Geforce 450 card will work with Ubuntu 11.04? Oh and I almost forgot, I tried booting 11.04 Beta1 LiveCD with my new Nvidia, and it actually started up into Gnome. But it wasn't using nvidia driver, so no eye candy or smooth desktop environment. Any clues if this Geforce 450 will work with nvidia driver on 11.04?

Thanks, Opt

  • have you tried starting in recovery mode? – RolandiXor Apr 14 '11 at 14:37

Ubuntu uses the Nouveau driver for nvidia cards. The GeForce GTS 450 card is from the NVC0 family. Unfortunately, support for this relatively new family is not complete and still in development. So, you can forget this driver for now, it might get better over a year.

I am not sure why ubuntu-x-swat contains a driver with version 270.41.03, because the properietary nvidia drivers (32bit and 64bit) are of version 260.19.44.

  • @Roland Taylor: No, I actually wasn't able to load recovery mode. I didn't remember at that point how to get into recovery mode. – user14239 Apr 14 '11 at 15:22
  • Does that mean that I should be able to use Geforce 450 with the Nvidia proprietary driver? I'm not actually interested in open source drivers, since I have not had that good experiences with them. I was also checking Nvidia official drivers and indeed seems they are 260.19.44. A bit strange that x-swat offers 270 version. – user14239 Apr 14 '11 at 15:31
  • 1
    @opt: I'm not guaranteeing anything, but it's worth to give it a shot. Please make a backup before proceeding, preferably using disk cloning software like Clonezilla. I had a bad experience with nvidia's proprietary drivers, which won't work with Optimus (on notebooks). – Lekensteyn Apr 14 '11 at 15:44
  • I will give it a try. I shall wait till I get a new hard drive, since I'd rather play safe. I have always had really good succes with nvidia driver with 7600GT. But now I wanted to upgrade to a faster card because with 7600 my desktop gets a bit laggy from time to time. Yes, I like to run with full effects and all the possible eye candy :) – user14239 Apr 14 '11 at 15:52

Problem solved. It was most probable an issue with weak/poor power supply. I installed the card on another PC and Ubuntu 10.10 worked just fine with restricted driver (and with open source driver also).

This question can be marked as solved.

Thanks, opt

  • 2
    You can mark this question as solved (or in SE terms answered) by accepting this answer by clicking on the tickmark below the vote count. – N.N. Jun 26 '11 at 10:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy