3

This is mystifying me. I have tried all other solutions that I could find and none seem to work. The 'appearance' menu has disappeared from settings. I'm using gnome-classic. Here's what I've tried so far:

1) Right click -> Change desktop background This just brings up settings

2) gnome-control-center background Same as above which is annoying. It also brings up this:

[_LOG_LEVEL_FATAL 12:41:31.369606] Switchboard.vala:201: Couldn't find background.plug among the loaded settings.
[_LOG_LEVEL_FATAL 12:41:31.369641] Switchboard will not function properly.

3) apt-get install gnome-control-center-unity to which I get E: Unable to locate package gnome-control-center-unity

16
  • In step 2, your error mentions Switchboard and a background.plug file. Are you running Elementary OS or Ubuntu with the Elementary desktop? Or having you installed the Elementary desktop in the past but now using gnome-classic?
    – iBelieve
    Sep 26 '13 at 13:23
  • Actually, now you mention it, I did yes. I briefly installed it but it didn't work so I thought I removed it.
    – andy
    Sep 26 '13 at 14:02
  • Which version of Ubuntu are you using? If 13.04, did you try reinstalling gnome-classic using sudo apt-get purge gnome-session-fallback;sudo apt-get install gnome-session-fallback
    – jobin
    Sep 30 '13 at 9:39
  • Currently on 12.04. Will that work on this version?
    – andy
    Sep 30 '13 at 10:34
  • Can you do this: sudo apt-cache check and sudo apt-get -yqq install debsums; debsums -s? If the first fails edit your question and add the results, if the second produce output the same.
    – Braiam
    Sep 30 '13 at 13:20
3

Just to followup: I never managed to fix the problem concerning the wallpaper dialog but I found a workaround to change it from the command line with this little script:

#! /bin/bash

path=$(cd $(dirname $1); pwd)/$(basename $1)
gsettings set org.gnome.desktop.background picture-uri file://$path
2

Looks like the control-center-unity package was deleted. Have you tried installing the .Deb package of control-center-unity from http://www.ubuntuupdates.org/package/core/saucy/main/base/gnome-control-center-unity ?

5
  • Thanks for this! Although, I'm trying to install it and it says I'm missing libgnome-desktop-3-7 (>= 3.2.0)
    – andy
    Oct 3 '13 at 12:15
  • Maybe this will help? pkgs.org/download/libgnome-desktop-3-7 If nothing else works, try purging gnome-classic and re-installing. as @jobin suggested. I think part of the problem might be an unmet dependency during the initial installation of gnome-classic.
    – APNW
    Oct 3 '13 at 12:20
  • Hmm, this is super frustrating. The first option didn't work and neither did apt-get purge gnome-panel && apt-get install gnome-panel
    – andy
    Oct 3 '13 at 12:29
  • Taking a wild chance, you could try installing Ubuntu-tweak tool and enabling desktop icons? No logic to my answer, but just that a few others have had this help.
    – APNW
    Oct 3 '13 at 14:42
  • That does help somewhat. I can right click on the desktop now and 'Change desktop background' but that just brings up the settings dialogue. Very weird
    – andy
    Oct 4 '13 at 8:36
1

Try going to synaptic and look for the packages

libgnome-control-center

you will probably see

libgnome-control-center-dev

libgnome-control-center1

Install them both and then try to access to your desktop settings to see.

3
  • libgnome-control-center-dev wasn't installed, but I still can't see the appearance menu
    – andy
    Oct 7 '13 at 10:53
  • Precisely, if it wasn't installed that's the missing component, just mark it for installation and apply the changes.
    – Irving
    Oct 10 '13 at 3:37
  • Sorry, I should've made it clear: It wasn't installed but it wasn't in the settings once I did end up installing it.
    – andy
    Oct 10 '13 at 7:30
1

You should remove the gnome panel.
Type in the terminal following code:

sudo apt-get purge gnome-panel && sudo apt-get install gnome-panel.
1
  • I've already tried that but it doesn't seem to fix the problem
    – andy
    Oct 7 '13 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.