I'll tell you the whole story.

I decided to upgrade my natty from alpha to beta after a long time.After the updates has been downloaded, the system crashed during installation. I rebooted the system and during the plymouth screen I greeted with the error message

"Disk Drive / not ready yet or not available"

and options to wait,skip or manually recover

If I choose to skip, it gives the same error,but with /tmp this time.

And if I skip again, it just freezes.

If I choose the option to manually recover, I get a maintenance shell.

Please help.

  • Thing I have already tried Waiting running fsck fsck -a, -p,-f mount -a running gparted on this drive from a different ubuntu partition Apr 14, 2011 at 6:10
  • After a system crash during updgrade your files or filesystem may be corrupted. This can best be fixed with a fresh reinstall.
    – Takkat
    Apr 14, 2011 at 7:48
  • I dont want to do it.Thats the whole point. Apr 14, 2011 at 8:02
  • I had the same error with a fresh install to 12.04. Worked out the same fix mentioned in Klaus' post.
    – ijk
    Aug 12, 2012 at 16:43
  • 1
    NOTE: This question is about the same issue. Hopefully, it can be useful for future users..
    – Lucio
    Feb 6, 2013 at 22:47

2 Answers 2


This code works fine on my machine (try it just once and the problem should be fixed):

mount -o remount, rw /

My Ubuntu is: Ubuntu 12.04: 3.2.0-49-generic #75-Ubuntu x86_64 GNU/Linux


I ran fsck in manual recovery. But I don't remember which atribute label I used - it was check partition and don't repair. I think it vas -r. Then console aked me if I wanted to fix this erorr. I pushed "y" for one hundred times and now system boot without problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .