19

How do I connect to my remote sftp account using ubuntu's "Connect to Server" option? When I have the "Connect to Server" dialog box on my screen, the "Service type" only shows:

FTP (with login)
Public FTP

Those are the only FTP options I can see in the dropdown. No SFTP option?

30

The easiest way to connect to an SFTP server with Ubuntu is with the sftp:// scheme of the file managers with GVFS support (Nautilus, Nemo, Thunar) or KIO support (Dolphin, Konqueror):

  1. Open a file manager window.

  2. Show or focus the address bar e. g. with Ctrl+L.

    (If this doesn't work your file manager may have an equivalent, alternative menu entry called “Go to…” or “Connect to…”. Some window manager require you to press Alt to show the menu bar.)

  3. Enter the server address into the address bar:

    sftp://example.org[:port]/
    

    You can even supply username, password, and a path in the address:

    sftp://[user[:password]@]example.org[:port]/[path/to/directory/]
    

    If you don't and the SFTP account requires a password, a password dialogue will pop up.

| improve this answer | |
  • You can do this for FTPS too btw (ftps://example.com). Interestingly, even though this works, the "connect to server" dialog does not offer FTPS as an option. And im wondering if that is what the OP is actually asking about (since people often confuse SFTP as FTPS). – dhaupin Oct 28 '16 at 18:53
8

Do you see an SSH option in the dropdown? That is effectively the SFTP option, you should see it listed as such on the left pane once it connects.

Or you can skip the File → Connect to Server… sequence altogether and instead do Go → Location (or Ctrl+L) and then typing sftp://user@host/initial/dir in the address bar.

| improve this answer | |
0

Ubuntu doesn't have ssh installed by default, so you have to install ssh on Ubuntu in order to connect to a remote SFTP account.

sudo apt install ssh
| improve this answer | |
0

As others have pointed out, it's pretty darn easy:

  • Open any folder in your local system.
  • press Ctrl + L , which will select the text in the address bar
  • clear that text and enter the following command in the address bar

    sftp://username@contact.server.de

That should get you through. However, you might have to enter the passphrase if you have protected your SSH key with one.

Note: small letter L works, there's no need to use a capital letter.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.