I have a sony viao Laptop installed with Ubuntu 12.04

rfkill list all
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: sony-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: sony-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
4: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

 sudo lshw -C network
       description: Wireless interface
       product: AR9485 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 01
       serial: a4:17:31:cc:25:3b
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=3.5.0-39-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 memory:c3000000-c307ffff memory:c0000000-c000ffff
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:0e:00.0
       logical name: eth0
       version: 07
       serial: 54:53:ed:33:a2:8b
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168e-3_0.0.4 03/27/12 ip= latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:41 ioport:2000(size=256) memory:c4404000-c4404fff memory:c4400000-c4403fff


eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=16 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

I have tried whatever I could find on forums but couldn't get wifi connected.

Here is the list of what i have tried.

Wireless is disabled by hardware switch on sony vaio

Added "blacklist sony_laptop" to /etc/modprobe.d/blacklist.conf

Also tried http://www.emmolution.org/?p=253

Also installed latest version ( here. http://wireless.kernel.org/en/users/Download/stable/#Recommended

It detects all the wifi's but wont connect. I can connect to my Binatone router using my android phone and mac air but not from Ubuntu. It was working fine till yesterday. But my laptop shut off after battery discharge and since then its not connecting. Please help me here. One is not supposed to waste a day trying connecting to wifi.

Thanks a lot.

  • Can you post the output of iwconfig as well? – Phoeey Sep 25 '13 at 10:03

This seems to be a duplicate of previous question: sony vaio WLAN problem using 12.04

All the Ubuntu answers I've seen have turned off hardware encryption with nowhcrypt=1 in the /etc/modprobe.d/ath9k.conf file, but I've seen Windows users complain that they also needed to turn off Power Management. If your card is configured as wlan0 you should be able to do that with sudo iwconfig wlan0 power off


Use the following commands:

sudo modprobe -r sony-wifi
cd /etc/modprobe.d
sudo nano blacklist.conf

Then add blacklist sony-wifi in a new line at the end of the file.

Now just save the file and reboot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.