This question already has an answer here:

I am new here. I just installed Ubuntu and I am very happy. I tried to install a program from Ubuntu Software Center. It said "Available from "universe" source". So I clicked "Use this source". So, the download started. But I have a problem. Just after a bit, it gives an error. It says "Failed to download repository information. Check your Internet connection". I was very confused.

Here are the error details:

    W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/main/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/restricted/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/universe/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/multiverse/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/restricted/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/universe/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring/multiverse/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/main/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/restricted/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/universe/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/multiverse/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/main/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/restricted/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/universe/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-updates/multiverse/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/main/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/restricted/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/universe/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/multiverse/source/Sources  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/main/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/restricted/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/universe/binary-i386/Packages  404  Not Found
, W:Failed to fetch http://pk.archive.ubuntu.com/ubuntu/dists/raring-backports/multiverse/binary-i386/Packages  404  Not Found
, E:Some index files failed to download. They have been ignored, or old ones used instead.

Please help? :(

I am trying to install 2 programs.

marked as duplicate by bain, Mitch Aug 3 '14 at 9:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


First, try out these couple of commands from the terminal:

apt-get autoclean
apt-get clean
apt-get autoremove

Open system settings (from terminal you may enter:)


Now click on Software Sources and under the Ubuntu Software tab, make sure every thing's checked and change the Download from: list control to Main Server.
Now you may try out downloading your apps again. (This worked for me before! In some rare cases a restart might help too.)

  • No, the first 3 commands didn't work, and I couldn't find any Ubuntu Software tab, nor any Software Sources button. I only find a Software & Updates button. – Hamza Shahzad Sep 24 '13 at 14:28
  • Try by adding sudo infront of them, eg: sudo apt-get autoclean – Python Student Sep 24 '13 at 15:47

just open nano /etc/apt/sources.list

and replace all 'pk' to 'us'


There appears to be no connection to the Internet. This could happen for various reasons. One of the reasons could be that you are behind a proxy server. A guide for Ubuntu to configure the proxy settings for various tools (incl apt-get) can be found on this website.

I also noticed that the pk.archive.ubuntu.com is not complete. The en.archive.ubuntu.com includes files that could not be found on the pk mirror. You might consider trying to change to the en variant by editing the /etc/apt/sources.list file. You might want to consider to read up a bit about apt-get and the sources.list file before changing anything and always make a backup before changing anything.

Not the answer you're looking for? Browse other questions tagged or ask your own question.