32

This seems like a typical use-case yet I can't find a way to do it- I created a layout having multiple windows. I want each window to open an SSH session to a different server.

2 Answers 2

30
  1. Go to the Layout tab in the configuration dialog,
  2. Select your layout
  3. In the terminal in the tree view in the middle, select your first terminal, select your profile and enter at the right the "custom command"
  4. Repeat step 3 for all your terminals where you want to run a special command at startup.

Use always the same layout and the same profile.

When done click on close and quit terminator.

When starting terminator again give the layout and the profile as command line option. ie. terminator -l Layout1 -p Profile1

If you always want this, add an alias to .bashrc.

6
  • 8
    I've tried setting custom directory and command through both UI and config file and none of the methods works for me. directory is simply ignored. Custom command will crash terminator or profile configuration.
    – yuranos
    Commented Feb 20, 2017 at 1:05
  • 8
    @yuranos87 try to open config file ~/.config/terminator/config and add command to one of the Terminal sections: command = cd /some/folder; bash
    – iamantony
    Commented Oct 10, 2017 at 9:40
  • 2
    Anything I put in 'command' causes a runtime error when terminator is loaded up the next time with the specified layout. It also corrupts the layout entry in the config file by adding too many windows and terminals. I'm running debian if that makes a difference.
    – atreeon
    Commented Jan 4, 2019 at 15:26
  • 3
    It is very important to add ; bash or ; zsh (depending on your shell) after each custom command in your layout. Then it works fine and opens all windows. Without it terminator might open only one window.
    – luke
    Commented Apr 9, 2019 at 8:27
  • The section is called custom_command. Fedora 31 here and it doesn't really work one way or the other. It just ignores the command but sets the correct background.
    – runlevel0
    Commented Jan 13, 2020 at 12:57
3

I worked with this for a while, and the ; bash advice is correct. One other piece of advice is after entering the custom commands in the Profiles area of Preferences, if you click Save, it will wipe out all of the custom commands. If you enter the custom commands and simply close the preferences window, the preferences are preserved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .