The headphone jack on my HP Pavilion dv6t works on Windows, but not on Ubuntu. Currently I'm running Ubuntu 13.04(Linux Mint 15 Cinnamon) with kernel 3.8.0-19. I've also ran Ubuntu 12.04/13.04 and many forks of them in the past couple of weeks. The headphone jack has not worked on any of them. The laptop speakers work without any issues, but it's annoying not to be able to use my headphones. As far as the headphones go, they work fine in my phone as well as other devices, so the headphones aren't the problem. Any help is appreciated. Let me know if I can provide anymore information about this issue to make it easier for you to help me(and any others that might have this issue). Thank you.


I had the same exact problem on my hp pavilion dv6. I have/still run Ubuntu 12.04 LTS, and although my laptop is the silver,brushed aluminum model, it shouldn't be too far fetched from your's.

Ubuntu uses this program called Alsa for its volume.

Alsa-website: (http://www.alsa-project.org/main/index.php/Main_Page)

Alsa comes preconfigured, but its not always configured to the right system. I had to go in and modify some of Alsa's configuration files using Gedit. I forget the exact details but it should come down to modifying some lines that say things like jack-1: mute to say jack-1: unmute

You can use Gedit or any other type of text editor. Make sure to use sudo to be able to save the modified copy.Also make sure to make a back up copy of the file just in case something wicked happens or if it just doesn't work, so that way nothing changes

  1. Went to the configuration file at /etc/modprobe.d/alsa-base.conf and modified a few lines of text. I am a little unsure if I did anything else (don't remember), but I still have the URL where i got the info. a user on Ubuntu Forums posted this large list of different systems and the right text to insert.
    (Found it at: http://ubuntuforums.org/showthread.php?t=1043568)

  2. Then (a few months later) I modified the configuration file at /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf. (found it at: My headphones mute AlsaMixer when I plug them in, HP DV6 12.04 )

Note: Step two I just finished today 2/13/14, so I have my fingers crossed on whether it will stay like this, but for now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.