After a shutdown or suspend, the machine appears to completely shutdown (all fans stop and are quiet), after a few seconds, everything is powered up again by itself.

Despite the many offered solutions here in the forum, my pc keeps on rebooting after shutdown and after suspend.

IMPORTANT UPDATE: it appears that the pc shuts down without restart when ZFS is performing a scrub. I assume this means that something is going wrong when the pc is shutting down with regards to ZFS (unmount? unshare ?). Any clues ?

  • I tried adding acpi=noirq to the grub file, after that I executed update-grub.
  • I tried adding acpi=no apm=no instead, but that caused suspend to not terminate properly and result in a reboot. Shutdown causes reboot like before.
  • Tried sudo halt, sudo shutdown -h now
  • Tried installing laptop-mode-tools in Ubuntu 12.10
  • De-activated WOL
  • I even tried to change "auto" to "on" in the "control" files for every device.
  • Upgraded to Ubuntu 13.04 (I believe laptop-mode-tools are not available under 13.04?)
  • Tried messing in the BIOS ACPI settings (switched everything off, with no result)

None of it seems to work, and I'm getting out of info on the forum...


  • Is there anybody that has an idea what could go wrong ?
  • Could ZFS be the cause ?
  • Or the fact that I have an additional pci-e network adapter ? (some WOL issue)
  • I'm not too familiar with Ubuntu, how can I access/dump the logtext when the system is going to shutdown or suspend (not the arrow key, but a file) ?

Running Ubuntu 13.04 now, with ZFS (6 disks) as a NAS on a ASRock B75 Pro3-M, Intel Pentium G2020, 16 Gb RAM, additional pci-e network adapter.


I have the same issue, my case is that it happens if on a session I had run any game from steam.

I've been trying to get help from askubuntu and steam forum, no one seems to be replying yet.

No idea what is the root cause yet and I don't have ZFS. I've also tried some of the possible fix that you've tried. Too bad is that I'm still very new to the Linux world and there is not much that I can help of

This is my observation:

  1. Switch off the psu and switch on again clears the effect sometimes
  2. Otherwise, the computer needs to be powered down for a period (around half a day) to remove the effect

My system: Ubuntu 13.04, PcPartPicker

  • Thank you for the assistance. Alas, it is not related to the PSU itself. – David Van Huffel Sep 27 '13 at 4:34
  • Man this issue is so annoying. It better be some software issue so that I don't have to RMA any new part I've just bought. – LaoPiSai Sep 27 '13 at 14:32
  • Should a bug be filed? I'm not sure how to do it professionally though. – LaoPiSai Sep 28 '13 at 4:52
  • I have no idea whether this is a bug or simply some setting issue, or even a hardware faillure – David Van Huffel Sep 28 '13 at 8:49

It appears a hardware failure was at the basis of it all. With a new motherboard, CPU and power supply it all seems to work!

  • Sure, with a new computer, you don't have the issue anymore. That's good to know. – ThEBiShOp Jul 12 '18 at 8:06

It appears that hardware issues indeed were at the basis of my issues. That's fixed now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.