1

I am currently attempting to set up a home server using Ubuntu 13.04. I am following instructions from http://linuxhomeserverguide.com/server-config/Webmin.php accurately as far as I can tell. I've made it past the installation on the host machine, and attempted to connect to it using ssh on my main PC.

I've tried establishing the connection using "ssh [user]@[hostname]" and many different variations using the server's ip address/user/hostname, however I'm constantly met with... "ssh: could not resolve hostname [hostname]: No such file or directory".

I have also confirmed that my host name is correct by typing "hostname" in the command line on the server.

I have very little experience with this sort of thing, and may be in over my head, but any help would be appreciated - thank you!

  • have you enable the correct port to bypass any firewall/router you may have? – amc Sep 23 '13 at 4:58
  • Port 22 if i'm not mistaken. Tried looking through my routers settings/ searching but couldn't figure it out. It's a motorola surfboard (forget which model, not near it ATM). Any ideas? – Fox Sep 24 '13 at 13:57
1

After a few afternoons of trying and scouring the internet, the answer I found was simply entering the commands

sudo apt-get install openssh-server

on the host machine, which I was sure I selected in the initial OS installation, and

sudo ufw allow 22

on both machines to make sure the necessary port was open. I then rebooted the host machine, and was able to connect.

Now on to the next brick wall!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.